Frozen touch screen - 2017+ Chrysler Pacifica Minivan Forums
 4Likes
Reply
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 01-31-2017, 01:21 PM Thread Starter
Senior Member
 
ezdays's Avatar
 
Join Date: Jul 2016
Location: Arizona
Posts: 311
Frozen touch screen

This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.

Don (ezdays) Day
ezdays is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 01-31-2017, 01:30 PM
Super Moderator
 
generaltso's Avatar
 
Join Date: Aug 2016
Location: Vermont
Posts: 2,583
If it happens again, hold in the Mute and Tune buttons together for about 5 seconds. That will reboot the Uconnect system.
Gohawks1224 and MajikMojo like this.

Ordered 9/19/16 -- Built 10/7/16 -- Delivered 10/27/16:
2017 Pacifica Limited - Molten Silver/Mocha
8 Pax - Vac - SafetyTec - UConnect Theater & Sound
20" Wheels - Tow - KeySense - Splash Guards
generaltso is offline  
post #3 of 11 (permalink) Old 01-31-2017, 02:23 PM
Senior Member
 
Join Date: Oct 2016
Location: Auburn Hills, MI
Posts: 418
Quote:
Originally Posted by ezdays View Post
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
Hi ezdays,

Sorry to hear about this! I'd be happy to follow up with your dealership for you if needed, just PM our page with your VIN and let me know.

Andrea
Chrysler Social Care Specialist
ChryslerCares is online now  
 
post #4 of 11 (permalink) Old 01-31-2017, 03:11 PM Thread Starter
Senior Member
 
ezdays's Avatar
 
Join Date: Jul 2016
Location: Arizona
Posts: 311
Quote:
Originally Posted by generaltso View Post
If it happens again, hold in the Mute and Tune buttons together for about 5 seconds. That will reboot the Uconnect system.
Thanks, I'll try that if it happens again.

Quote:
Originally Posted by ChryslerCares View Post
Hi ezdays,

Sorry to hear about this! I'd be happy to follow up with your dealership for you if needed, just PM our page with your VIN and let me know.

Andrea
Chrysler Social Care Specialist
Thanks Andrea, I'll do that if it continues to happen, but I'll try generaltso's advice first to see what that does.... It only happened the one time, a reboot is a lot easier than a trip to the dealer...
ChryslerCares likes this.

Don (ezdays) Day
ezdays is offline  
post #5 of 11 (permalink) Old 02-19-2017, 04:42 PM
Junior Member
 
Join Date: Dec 2016
Posts: 2
Quote:
Originally Posted by ezdays View Post
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
I got on here to see if anyone else had this issue!!! This has happened to me now FOUR TIMES and I've only had my van for a month. I've never wanted to scream so much. Four kids in the back wanting their movie sound on and there was literally nothing I could do. I did like you and turned it off & on, I tried going through voice control but as soon as I'd try hitting a button on the screen it would go back to climate!? I keep saying, if it happens again, I'll go to the dealer. I just don't have time! I'm really praying this magic reset solution works next time!

Quote:
Originally Posted by generaltso View Post
If it happens again, hold in the Mute and Tune buttons together for about 5 seconds. That will reboot the Uconnect system.
Thank you for this!!!! I really hope this works next time! I'm not in the van now but are both of those buttons hard buttons on the panel?
BBMommy is offline  
post #6 of 11 (permalink) Old 02-19-2017, 04:58 PM
Super Moderator
 
generaltso's Avatar
 
Join Date: Aug 2016
Location: Vermont
Posts: 2,583
Quote:
Originally Posted by BBMommy View Post
Thank you for this!!!! I really hope this works next time! I'm not in the van now but are both of those buttons hard buttons on the panel?
Yes, they are the buttons in this middle of the volume and tune knobs.
BBMommy likes this.

Ordered 9/19/16 -- Built 10/7/16 -- Delivered 10/27/16:
2017 Pacifica Limited - Molten Silver/Mocha
8 Pax - Vac - SafetyTec - UConnect Theater & Sound
20" Wheels - Tow - KeySense - Splash Guards
generaltso is offline  
post #7 of 11 (permalink) Old 02-19-2017, 07:19 PM
Senior Member
 
Gohawks1224's Avatar
 
Join Date: Aug 2016
Location: Oak Harbor, Washington
Posts: 897
Garage
Quote:
Originally Posted by ezdays View Post
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
I suggest turning the defrost on to thaw out your screen.

Father of thing 1, thing 2, thing 3, thing 4 is getting a minivan.
2017 Chrysler Pacifica Touring L Plus with Tow, Advance Safety, 8 passenger, Tire/wheel, and Nav.
*Ordered 1FEB and delivered 20MAR2017

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Gohawks1224 is offline  
post #8 of 11 (permalink) Old 02-19-2017, 08:41 PM Thread Starter
Senior Member
 
ezdays's Avatar
 
Join Date: Jul 2016
Location: Arizona
Posts: 311
Quote:
Originally Posted by Gohawks1224 View Post
I suggest turning the defrost on to thaw out your screen.
In the middle of the Arizona desert, naw, if it happens again, I'll turn on the A/C just in case the screen was overheated

Don (ezdays) Day
ezdays is offline  
post #9 of 11 (permalink) Old 06-14-2017, 09:59 PM
Junior Member
 
Join Date: Jun 2017
Posts: 3
I also have a month old Pacifica 2017 and I am having the same problem. I has happened to me 5 or 6 times and I have learned to stop, turn off the car, and open my door to truly shut everything off. Found that you need to sit for at least 3 to 5 minutes before restarting. So far this has corrected the problem for the rest of the day at least. The problem so far generally only occurs on the first start up of the day and once fixed has not reoccurred again the same day. I'm not looking forward to a dealer visit unless I should have the screen frozen and will not shut off the engine until I am at the dealer and have shown them the problem. Doubt they will be all that impressed if they shut down like I do and everything then works fine.
kingyip is offline  
post #10 of 11 (permalink) Old 06-14-2017, 10:25 PM
Junior Member
 
Join Date: Jun 2017
Posts: 3
2017 Chrysler Pacifica Frozen Touch Pad

Picked up my Pacifica one month ago and this screen has frozen on me 5 or 6 times. Really a pain. I think I rebooted UConnect as others have suggested but without effect. I have found that if I stop, shut off the car, even open my door to fully remove energy from this system and then wait 3-5 minutes, it will come up and work fine. If I immediately restart, it can stay frozen. This seems to happen to me usually on the first engine start up of the day and once corrected as above, everything works fine the rest of the day.
Will only go to the dealer if I get a frozen screen and can take to the dealer without shutting off the car, but doubt they will be impressed if they shut the car off, restart and everything works.
Wondered if you are still having the problem and is so did Chrysler respond and if so how??
kingyip is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2017+ Chrysler Pacifica Minivan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchscreen and LCD Screen Issue tacohen Chrysler Pacifica Minivan Issues And Problems 14 Yesterday 08:51 AM
Screen protector for 8.4 Uconnect irpilot Accessories And Add Ons 45 06-16-2017 05:15 PM
Radio, climate control, LCD screen dying Pacifica Phil Chrysler Pacifica Minivan Issues And Problems 1 01-30-2017 12:24 PM
Uconnect Screen Problem! ganymede81 Chrysler Pacifica Minivan Issues And Problems 10 09-08-2016 08:44 PM
uConnect theater screen defective VoltNow Electronics 2 08-19-2016 01:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


SEO by vBSEO 3.6.1