Sudden Power Loss While @ 70 MPH - 2017+ Chrysler Pacifica Minivan Forums
 1Likes
  • 1 Post By ChryslerCares
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10-15-2018, 10:06 PM Thread Starter
Junior Member
 
Join Date: Oct 2018
Posts: 3
Unhappy Sudden Power Loss While @ 70 MPH

My family and I were riding along at 70 MPH and suddenly, the left side energy consumption meter started bouncing up and down. Some burnt rubber smell came through the vents and then the car just start slowing down. I was lucky there were no cars around me and was able to make it across 4 lanes to the right hand side shoulder. All of the lights on my dash were lit but the engine department obviously dead. I powered the car down and tried to crank it again but the computer was confused about which gear I was in. Now, the dash only showed the engine light and battery light. After trying this several more times, I gave up and called the FCA tow truck which was a horror story all on its own. Took me longer to get and FCA rep online and conversation finalized (30 min) than it took the tow truck to get to my location (15 min). Before the tow truck got to my location, I was able to start the car in gas mode after it died 45 minutes ago and hobbled over to a gas station a 200 feet away. The smell was still prevalent at this point. The tow truck towed the van to the service department where I bought the van (Covert in Austin) which just happened to coincide within the 10 miles towing limit for my case. This happened 10/6/2018. It's been 9 days and my van hasn't been looked at yet. Apparently there aren't enough Hybrid techs to go around. Covert which is a larger FCA dealership in the Austin area only has 2 techs. In the mean time, Covert lent me a loaner since the day I dropped the van off. Not sure what the problem is or when it will be fix. But this doesn't look promising.

Last edited by lamchakchan; 10-16-2018 at 11:23 AM.
lamchakchan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-15-2018, 11:00 PM
Senior Member
 
Join Date: Oct 2016
Location: California
Posts: 1,453
Quote:
Originally Posted by lamchakchan View Post
My family and I were riding along at 70 MPH and suddenly, the left side energy consumption meter started bouncing up and down. Some burnt rubber smell came through the vents and then the car just start slowing down. I was lucky there was no cars around me and was able to make it across 4 lanes to the right hand side shoulder. All of the lights on my dash were lit but the engine department obviously dead. I powered the car down and tried to crank it again but the computer was confused about which gear I was in. Now, the dash only showed the engine light and battery light. After trying this several more times, I gave up and called the FCA tow truck which was a horror story all on its own. Took me longer to get and FCA rep online and conversation finalized (30 min) than it took the tow truck to get to my location (15 min). Before the two truck got to my location, I was able to start the car in gas mode after it died 45 minutes ago and hobbled over to a gas station a 200 feet away. The smell was still prevalent at this point. The tow truck towed the van to the service department where I bought the van (Covert in Austin) which just happened to coincide within the 10 miles towing limit for my case. This happened 10/6/2018. It's been 9 days and my van hasn't been looked at yet. Apparently there aren't enough Hybrid techs to go around. Covert which is a larger FCA dealership in the Austin area only has 2 techs. In the mean time, Covert lent me a loaner since the day I dropped the van off. Not sure what the problem is or when it will be fix. But this doesn't look promising.
Sorry to hear of your problem. I don't have a hybrid, but there are a couple threads you might be interested in.
https://www.pacificaforums.com/forum...to_threadtools
https://www.pacificaforums.com/forum...to_threadtools

The threads may not be directly related to your problem, but you may figure out who else has a hybrid.
If you put your van info (year, trim, gas/hybrid, etc.) in the signature line of the UserCP it will show up at the bottom and assist others answering your questions.

2017 Pacifica Touring L (gas) - Sept. 2016 build
SciTchr is online now  
post #3 of 4 (permalink) Old 10-17-2018, 05:04 PM
Senior Member
 
Join Date: Oct 2016
Location: Auburn Hills, MI
Posts: 1,952
Quote:
Originally Posted by lamchakchan View Post
My family and I were riding along at 70 MPH and suddenly, the left side energy consumption meter started bouncing up and down. Some burnt rubber smell came through the vents and then the car just start slowing down. I was lucky there were no cars around me and was able to make it across 4 lanes to the right hand side shoulder. All of the lights on my dash were lit but the engine department obviously dead. I powered the car down and tried to crank it again but the computer was confused about which gear I was in. Now, the dash only showed the engine light and battery light. After trying this several more times, I gave up and called the FCA tow truck which was a horror story all on its own. Took me longer to get and FCA rep online and conversation finalized (30 min) than it took the tow truck to get to my location (15 min). Before the tow truck got to my location, I was able to start the car in gas mode after it died 45 minutes ago and hobbled over to a gas station a 200 feet away. The smell was still prevalent at this point. The tow truck towed the van to the service department where I bought the van (Covert in Austin) which just happened to coincide within the 10 miles towing limit for my case. This happened 10/6/2018. It's been 9 days and my van hasn't been looked at yet. Apparently there aren't enough Hybrid techs to go around. Covert which is a larger FCA dealership in the Austin area only has 2 techs. In the mean time, Covert lent me a loaner since the day I dropped the van off. Not sure what the problem is or when it will be fix. But this doesn't look promising.
Hi lamchakchan,
We're very sorry that you have experienced this! Please send us a private message so we can gather more information from you to have this sent to a Case Specialist.
Lydia
Chrysler Social Care Specialist
CentralFla likes this.
ChryslerCares is online now  
 
post #4 of 4 (permalink) Old 10-21-2018, 01:15 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Posts: 3
After 2 weeks, an update from the dealership. There is an outstanding recall on the catalytic converter and they are going to do the work on it on top of some gasket which is connected to this system. This is something FCA told them to start off with. So once the repair done which is awaiting on parts, they are going to assess any other problems remaining. Still don't see an end in sight. But at least my car is being looked at now.

2018 Chrysler Pacific Limited Hybrid
lamchakchan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 2017+ Chrysler Pacifica Minivan Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Extended Warranty Worth It? Neogeo Chrysler Pacifica Minivan Warranty 230 08-05-2019 04:51 PM
Power Sliding Door Stops Working Temporarily (W DMR89 Chrysler Pacifica Minivan Issues And Problems 9 01-19-2019 09:44 AM
Loss of Power Steering gibsonsean97 Chrysler Pacifica Minivan Issues And Problems 7 05-22-2018 07:55 AM
Loss of power Tiago 2017+ Chrysler Pacifica PHEV Hybrid General Discussion 16 04-24-2018 09:16 AM
Recall for Sudden Loss of Motive Power kellyk82 Chrysler Pacifica Minivan Recalls 157 03-14-2018 08:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome