2017+ Chrysler Pacifica Minivan Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have one of the first 2017s and it has randomly jolted between 1st and 2nd gear since the first month I bought it. I took it to two separate dealerships and was told they "had no clue" and since it was random and not frequent, they couldn't test for it. They did say that software updates would help, but they didn't. Also, now that it's cold our seat warmers won't work. They come on for 10 seconds, but then turn off and won't warm at all. The transmission has been from the beginning, but the seats started messing up about the time the warranty expired. Has anyone else ever been able to get either of these issues fixed?
 

·
Registered
2017 Pacifica Touring L (9/2016 Build)
Joined
·
2,159 Posts
I have one of the first 2017s and it has randomly jolted between 1st and 2nd gear since the first month I bought it. I took it to two separate dealerships and was told they "had no clue" and since it was random and not frequent, they couldn't test for it. They did say that software updates would help, but they didn't. Also, now that it's cold our seat warmers won't work. They come on for 10 seconds, but then turn off and won't warm at all. The transmission has been from the beginning, but the seats started messing up about the time the warranty expired. Has anyone else ever been able to get either of these issues fixed?
It is better to search the forum and separate thread topics before starting a new thread.

There are plenty of transmission threads that I've posted in.
I haven't had problems with heated seats, but if you search the forum you may find info.

If you put your van info in the signature line of account settings it will show up at the bottom of each post. Build date is on the driver's door edge.
 

·
Registered
Joined
·
2,577 Posts
I have one of the first 2017s and it has randomly jolted between 1st and 2nd gear since the first month I bought it. I took it to two separate dealerships and was told they "had no clue" and since it was random and not frequent, they couldn't test for it. They did say that software updates would help, but they didn't. Also, now that it's cold our seat warmers won't work. They come on for 10 seconds, but then turn off and won't warm at all. The transmission has been from the beginning, but the seats started messing up about the time the warranty expired. Has anyone else ever been able to get either of these issues fixed?
Hi BrenPar,

We certainly regret to hear of your concerns! Please feel free to follow up via private message if you are unable to receive more feedback from here. We would be happy to see how we can assist.

Alex
Chrysler Cares
 
1 - 3 of 3 Posts
Top