2017+ Chrysler Pacifica Minivan Forums banner

181 - 200 of 207 Posts

·
Registered
Joined
·
1 Posts
I had u20 update performed 1 month ago. No problems anymore!

Now if I had only not had u73 done apparently...
I have same symptoms, 2018 hybrid Touring Plus (base model, I think) and I've been googling for "u20" - can you provide any additional detail about what this is and how I might get it? Is it a Chrysler recall?

Thanks very much!
- Steve
 

·
Registered
Joined
·
560 Posts
I have same symptoms, 2018 hybrid Touring Plus (base model, I think) and I've been googling for "u20" - can you provide any additional detail about what this is and how I might get it? Is it a Chrysler recall?
Not sure what he is referring to as a U20 recall. There is a bulletin out that might address your symptoms. Since you have a Touring Plus you will have not received this update over the air, so you will need to take it to the dealer and they can apply the update from a USB drive. Don't know exactly which radio you have, but one of these updates should apply:

https://www.dropbox.com/s/y700syv722wcis4/08-050-18 REV. A without AMP.pdf?dl=0
https://www.dropbox.com/s/ep2lm42u2xcg2xs/08-056-18 REV. A with AMP.pdf?dl=0

You can tell which software version you have by pressing the driver's side temperature up and down and the front defrost button, all three together for 5-7 seconds. That will get you to the dealer mode page, from which you get to System Information and Radio Part Information. The "Application Version" number in the bulletins is embedded in a string following your region (USA or CAN) and some other stuff. Note that the screenshot in the bulletin is an old one and references an old version.
 

·
Registered
Joined
·
22 Posts
Anyone have the update so we can flash ourselves? Hate having to schedule and drop car off for something we can do ourselves.

Sent from my SM-G892U using Tapatalk
 

·
Registered
Joined
·
1 Posts
2018 Pacifica and a black screen

I just installed the upgraded radio with Apple CarPlay and Android Auto in my 2018 Pacifica. When I initially installed it the radio worked perfectly however when I shut the car off and start it back up again the screen is blacked out but still functional. Do anyone know why this is happening and how I can fix this?
 

·
Registered
Joined
·
14 Posts
Just wanted to quickly chime in to say that, after a year of weekly (or more) black screens on the uConnect main console, I finally got a software update from the dealership about 4 weeks ago. I haven't had even a hit of a problem since. As long as that holds true, I can finally say that the PacHy is the best minivan money can buy.
 

·
Registered
Joined
·
20 Posts
Just came back from the dealer to apply the update via bulletin: 05-050-18 REV.A
I've had issues with charging schedule, lock screen, blank screen, resets, locked controls, bluetooth cracking...
I did not receive any OTA updates since I purchased the van in July, UConnect never showed me an update.

Was running software 17.37.29 and app 19.7
Now running software 18.20.2e and app 21.9

I have a Canadian 2018 Touring Plus with Nav.
Will update if this update fixes my issues, so far I'm only missing the rear climate controls but I think they'll just eventually re-appear (...?)
 

·
Registered
Joined
·
1 Posts
Bobby - driving in the mountains of Pennsylvania as we speak AND SAME THING has happened to my Mom's car. So annoying. The only reason I was looking is to see if there was something we could do. So aggravating - this will be the FIFTH time in nine months that my Mom has had to take it to the dealership.

Not good.
 

·
Registered
Joined
·
20 Posts
Just came back from the dealer to apply the update via bulletin: 05-050-18 REV.A
I've had issues with charging schedule, lock screen, blank screen, resets, locked controls, bluetooth cracking...
I did not receive any OTA updates since I purchased the van in July, UConnect never showed me an update.

Was running software 17.37.29 and app 19.7
Now running software 18.20.2e and app 21.9

I have a Canadian 2018 Touring Plus with Nav.
Will update if this update fixes my issues, so far I'm only missing the rear climate controls but I think they'll just eventually re-appear (...?)
My updates, overall I'm pretty happy.

The good:
- No longer getting blank, frozen or security screens on main display
- No sudden main screen crash/restarts
- Steering controls always worked
- Remembers the last screen displayed
- Radio feels more responsive
- Different/better audio beeps for the backup sensors
- Charging schedule works better, see below...
- Bluetooth connection is better, see below...
- Rear climate re-appeared and is always available
- My work charger correctly tells me my car is charged, instead of immediately after plugging

The bad:
- Charging schedule works better, but not completely fixed. Missed one charge so far.
- Bluetooth connection is better, but not completely fixed as I still get some crackling.
- Once got a blue screen for the back up camera, said it was unavailable. Hasn't happened again.
 

·
Registered
Joined
·
1 Posts
black screen

my 2018 Pacifica Limited started with black screen days after buying, took it to dealership was there for 3 weeks, they replaced the radio, next day doing it again. I am beyond frustrated. I have no updates that need to be done. please help.
 

·
Registered
Joined
·
69 Posts
Just wanted to share... I have a 2019 PHEV Limited, and the screen froze up on me back on 1/10 during a long trip. Unfortunately, it froze at the beginning of the trip so I was stuck with the seat heater on for the whole trip :)

So, not a black screen, but it did freeze and was completely unresponsive. It was pretty annoying. Turning the car off and then on (including opening the door and walking away with the key for 15 minutes) didn't resolve it. I didn't try pulling the fuse, or holding down the two buttons because I didn't read about this issue prior to it happening. The next morning I was armed with this info, but when I turned the car on everything was working fine.

So... hope that doesn't happen again.

Anyway, I figured I'd share as I'm pretty sure I have all the latest software updates with the 2019.
 

·
Registered
Joined
·
14 Posts
Not only does my screen black about 3-4 times a month but I can be driving down the road and my screen will turn blue then the back up camera comes on. Nothing can be done except pulling over, turning off van and restarting. That is real practical! My display directly in front of stearing wheel will go blank also, randomly. Chrysler Cares is a joke! Haven’t gotten anywhere with that except a case number.
 

·
Registered
Joined
·
183 Posts
You can add me to the 'Black Screen Brigade'. Like many others, the Uconnect screen of my brand-new, leftover (July build) '18 PacHy Ltd went dark a couple days after I got it home. It stayed that way for the rest of the day with nothing working (including back-up camera). This was a Saturday night and I figured if it didn't come back by Monday morning, I'd be paying my nearest FCA dealer a visit. Well, it had returned upon start-up on Sunday. But it wasn't all beer-and-skittles as all of the settings had reset to default and all nav locations were gone. Fortunately, there weren't many at that early stage.

Since it appears this happens soon after taking possesion, maybe it's some sort of over-the-air update?

It's worth noting that the driver instrument screen 'also' locked-up (just had the 'Hybrid' wallpaper) a day or two later, but that was much shorter in duration. I think it came back the next time I stopped, shut the vehicle off, and started up again.

These gremlins are the types of things FCA needs to get on top of right away, or the PacHy is going to garner a reputation as a lemon, very quickly. Once that happens, they won't be able to give them away. It's starting to remind me of one of the darkest periods in Chrysler history, that being the introduction of the dramatic 'Suddenly It's 1960!' 1957 'Forward Look', big fin Chrysler products. They were so popular that, in the rush to get as many of them built as possible, there was, literally, no quality control with lemon after lemon being sold. It was the beginning of Chrysler's horrible quality reputation that has lasted to this day. It became so bad that it wasn't much later that Chrysler was forced to offer it's famous 5-year/50,000 mile warranty in an attempt to recover.
 

·
Registered
Joined
·
685 Posts
I love my Pacifica. But... this is the first car after more than 20 years driving other brands , from Hyundai to Toyota, that I carry a pliers in my central console to remove the Fuse 76 from time to time. It's a shame that we have these issues in a car like our Pacificas.
 

·
Registered
Joined
·
183 Posts
I love my Pacifica. But... this is the first car after more than 20 years driving other brands , from Hyundai to Toyota, that I carry a pliers in my central console to remove the Fuse 76 from time to time. It's a shame that we have these issues in a car like our Pacificas.
Maybe subsequent Pacificas will include a fuse puller as standard equipment, along with its own little holder, and instructions in the manual as to the location of Fuse 76.

It's actually rather nostalgic for us old-time geezers, harkening back to the days when wise Mopar owners always carried a spare ballast resistor in their glove compartment.
 

·
Registered
Joined
·
685 Posts
Maybe subsequent Pacificas will include a fuse puller as standard equipment, along with its own little holder, and instructions in the manual as to the location of Fuse 76.

It's actually rather nostalgic for us old-time geezers, harkening back to the days when wise Mopar owners always carried a spare ballast resistor in their glove compartment.
It would be funny if it was not because we are talking here about a 40k car. :frown2:
 

·
Registered
Joined
·
10 Posts
I've pretty much given up on my Uconnect...in 4 years I'll dump it and it'll be my last FCA vehicle for a while. My Uconnect update in July failed. Chrysler Cares opened a case saying I needed a new unit. The dealership said the case doesn't mean anything and couldn't reproduce the blacking out, the anti-theft code etc. issues. Their system says there's no update for that unit. 7 months later, the update prompt came up again and it failed (surprise!). I scheduled it to run again, but nothing. I don't know what update is supposed to be happening since the dealership says there isn't one.

As a side note, by trunk stopped working cause the latch needed a software update (really?). The VRM module crapped out too. Basically, FCA stinks at technology...zero confidence in any of the technology. If can't get a radio to stay on, why would I trust other things like the emergency braking (it slammed on the brakes for a pedestrian in a parking lot like 30 feet away).
 

·
Registered
Joined
·
1,148 Posts
Service Bulletin 08-003-19,
Dated January 12, 2019

SUBJECT:
Radio and Back-up Camera Enhancements

NOTE: This bulletin applies to “2019” RU vehicles built on or before October 31, 2018 (MDH 1031XX) -

SYMPTOM/CONDITION:

Customers may experience one or more of the following:
• Blank rear camera image in reverse (If this is the customer concern use camera LOP 18-60-02-
D3, DT only).
• Audio cutting in and out during memory recall.
• Ring tone too loud.
• AM/FM volume fluctuates.
• While in CarPlayTor Android Auto GoogleTmaps showing wrong location.
• Phone disconnected after first call.
• Black screen or White screen with vertical lines.
• Personal Identification Number (PIN) clears and volume locked while KeySense is used.
• Audio static while in SXM/SAT modes.
• Echo heard during Bluetooth phone calls.
• The radio is locked up.
• The radio remains on after ignition has been turned off.
• The radio resets.
• The radio screen turns black.
• Intermittently requires an anti-theft code to be entered.


OVERVIEW:
This bulletin involves updating the radio software level to 1828.08
MODELS:
**2019 (WD) (Dodge Durango)
2019 (WK) (Jeep Grand Cherokee)
2019 (LD) (Dodge Charger)
2019 (LA) (Dodge Challenger)**
2019 (RU) Chrysler Pacifica
2019 (DT) RAM 1500 Pickup
2019 (KL) Jeep Cherokee
NOTE: This bulletin applies to vehicles within the following markets/countries: NAFTA,
APAC, EMEA and LATAM.
NOTE: This bulletin applies to RU vehicles built on or before October 31, 2018 (MDH 1031XX)
equipped with one of the following radios:
This bulletin applies to DT vehicles built on or before November 01, 2018 (MDH
1101XX) equipped with one of the following radios:
This bulletin applies to KL vehicles built on or before October 15, 2018 (MDH 1015XX)
equipped with one of the following radios:
**This bulletin applies to WD and WK vehicles built on or before December 20, 2018
(MDH 1220XX) equipped with one of the following radios:
This bulletin applies to LA and LD vehicles built on or before December 20, 2018
(MDH 1220XX) equipped with one of the following radios:**
• Uconnect 3 with 5” Display (Sales Codes UAA, UCA or UJA).
• Uconnect 4 with 8.4” Display (Sales Codes UAM, UCM, UDM, UGM or UJM).
• Uconnect 4 with 7” Display (Sales Codes UAG, UCG, UDG, UJG, ULG or UGG)

https://www.dropbox.com/s/g4v3na9iw1rgbm4/08-003-19 Radio and Backup camera Enhancements.pdf?dl=0
 

·
Registered
Joined
·
39 Posts
Dealership ordered a new screen a month ago. Still waiting for repair. Will post here if problem is resolved with new screen.
My problem ended up being simple bad screen on driver side theater seat. Dealership replaced screen under warranty and no more issues with hot seat area below screen and blank screen.
 

·
Registered
Joined
·
11 Posts
Thanks much for this info @m0ebius604. Do you also have firmware to share in dropbox? It seems the update process is fairly simple similar to smart phone firmware update.

I purchased a 2018 PacHy touring L two weeks ago, and got the blank/black screen issue yesterday without any obvious reasons. Follow the F76 trick it's acting normal now. I looked up my VIN in uconnect website but it says no current update available. Apparently uconnect website is not up to date.

My firmware is NA_NN-NC-ER-SBX-19.7.0-20170913-E071. It looks like to be produced in 2017-09-13 which is super outdated. Last week I just had my van fixed the pop noise from speaker when entering the car, since I can reproduce the issue very easily. What's the best way to convince the dealership to work on this Service Bulletin 08-003-19? Just show them the print out? What if they really want you to show them the blank/black screen?

Thanks in advance!
 
181 - 200 of 207 Posts
About this Discussion
206 Replies
93 Participants
m0ebius604
2017+ Chrysler Pacifica Minivan Forums
PacificaForums.com - A forum community dedicated to Chrysler Pacifica owners & enthusiasts. Come join the discussion about upgrades, towing capacity, reliability, and more!
Full Forum Listing
Top