2017+ Chrysler Pacifica Minivan Forums banner

201 - 207 of 207 Posts

·
Registered
Joined
·
1,148 Posts
Thanks much for this info @m0ebius604. Do you also have firmware to share in dropbox? It seems the update process is fairly simple similar to smart phone firmware update.

I purchased a 2018 PacHy touring L two weeks ago, and got the blank/black screen issue yesterday without any obvious reasons. Follow the F76 trick it's acting normal now. I looked up my VIN in uconnect website but it says no current update available. Apparently uconnect website is not up to date.

My firmware is NA_NN-NC-ER-SBX-19.7.0-20170913-E071. It looks like to be produced in 2017-09-13 which is super outdated. Last week I just had my van fixed the pop noise from speaker when entering the car, since I can reproduce the issue very easily. What's the best way to convince the dealership to work on this Service Bulletin 08-003-19? Just show them the print out? What if they really want you to show them the blank/black screen?

Thanks in advance!
Sorry guys, I don't have the firmware. I would have provided it if I could.

If you missed the OTA update then you’ll have to make an appointment to have it done at the dealership. There’s no way to have it them push the update again that I am aware of.

Make your complaint match several symptoms listed in the bulletin when your making your appointment and bring a printout or have the pdf available to show the advisor when you check in to save the run around.

This should streamline the process.
 

·
Registered
Joined
·
11 Posts
Hi @lacompas

I have a Canadian 2018 Touring L w/o Nav. Currently the software is exactly same as your old one. I visited the dealer today but they decide to replace the entire multimedia console screen:surprise: I was initially hoping the dealer would spend 1 hour to update the software but ended up having to wait 10~15 days for a new radio console.

Does this happen to anyone else in the forum? I wonder if Chrysler have a new batch of the hardware in 2019 which supports the software better?



Just came back from the dealer to apply the update via bulletin: 05-050-18 REV.A
I've had issues with charging schedule, lock screen, blank screen, resets, locked controls, bluetooth cracking...
I did not receive any OTA updates since I purchased the van in July, UConnect never showed me an update.

Was running software 17.37.29 and app 19.7
Now running software 18.20.2e and app 21.9

I have a Canadian 2018 Touring Plus with Nav.
Will update if this update fixes my issues, so far I'm only missing the rear climate controls but I think they'll just eventually re-appear (...?)
 

·
Registered
Joined
·
1 Posts
One Solution

I did manage to find a potential solution for this issue. Seems my troubles started when using the 110v charger. I would unplug the charger and the whole system was haywire. I did a few tests of my own and with the knowledge of my electrical engineering background I found the issues are caused by dirty power "Noise on the power line". Their is absolutely no noise protection in the circuitry. Computers require clean and noise free power else they crash. The solution is a simple and cheap power conditioner. The cost between $75 and $200 on amazon. Be sure and get one that has a 15 amp rating or better. Once I added the power conditioner to my charger I have never had the black screen of death or any other issues. Tested this theory on my neighbor's car as they have the same year model and it worked for him too. Would like to add one other thing. I did purchase a high end fast charger that does have EMI line noise suppression and have not had any other issues with my home charging however I have found some public charging stations to cause issues. I am working on designing an adapter that will filter out the line noise at the car plugin.
 

·
Registered
Joined
·
12 Posts
So I had thought we had the dreaded black screen issue last night. One rear screen went black while the other was fine. Perfect timing as we’re about to hit the road on a long trip lol. I drive with the dash lights just below the click for daytime brightness while my wife likes it on full bright.. even at night. The kids were watching a movie and I happened to end up driving us home from an outing and partway home, I rolled the dimmer down just past the bump to rid myself of the ridiculous glare and that’s when the screen went blank. After some investigating, the rear screens enter a day/night mode with the dash lights and hold a separate brightness setting for each mode. Somehow, the one screen had its brightness set all the way down in night mode which basically made it black. Put back into day mode at a light so we could see the screen and pressed the reset button on the rear screen which brought the brightness for night mode back to a normal level. I suspect this has already been discussed in here but I was all set to pull the fuse when I got home and wanted to save others the trouble IF it just happens to only be this issue (I do realize there are actual issues with uconnect, thankfully this wasn’t one of them!).
 

·
Registered
Joined
·
2 Posts
2019 Touring L Plus with 8.4" UConnect, I started getting the following error when launching the UConnect Theater app: Screen shows the Uconnect Theater (launching) but has an error message at the bottom left saying "Remote is locked out while in rear media." Moments later it would jump back to a map screen.

No idea what this means or what causes it. I did pull and reinstall fuse 76 which at first removed more than half of my UConnect apps....wife was not happpy...we let the car sit over night and next morning put it into RUN mode (pushing the start button twice without foot on brake) Upon loading icons returned, at first as blank "U" icons and then after a 2 minutes the icon images loaded as normal.

Anyone else experience this? I checked for an update on the Uconnect website with my VIN, says I am up to date. Is there a more simple soft reset? I've read too many different reset variations, not sure which one if for the 8.4" UConnect.
 

·
Registered
Joined
·
1 Posts
I have this issue now! I bought my 2017 two weeks ago and now my screen is black and no radio. Dealership said can’t get me in for five days... 5 days seriously?!! And then the lady says it’ll take a few hours and I’ll have to pay $99. Are you kidding me?!? I am soooo irritated and at this point will never suggests Chrysler.
 

·
Registered
Joined
·
1,148 Posts
I have this issue now! I bought my 2017 two weeks ago and now my screen is black and no radio. Dealership said can’t get me in for five days... 5 days seriously?!! And then the lady says it’ll take a few hours and I’ll have to pay $99. Are you kidding me?!? I am soooo irritated and at this point will never suggests Chrysler.
They will always tell you that the hour diag will be charged to you if it turns out not to be a warrantable issue.. but you should almost never actually be charged this unless the problem is caused by abuse, wear and tear or is out of its specific warranty period -ie: squeeks and rattles typically gets 1 year or a pre-defined mileage. After which a squeaks and rattles complaint would only be covered if it happens to be caused by a defective part that is covered by warranty.

Same for bluetooth issues.. these tend to become billable because no one thinks the problem is the phone!.. if its not the vehicle causing the complaint, its not covered by warranty. Now heres the catch, if you dont leave your phone with the vehicle the complaint will most likely not be reproduced! No one leaves their phone.. and the dealer could charge you for the diagnostic time.

The blank screens is a well known issue and should be covered.
 
201 - 207 of 207 Posts
About this Discussion
206 Replies
93 Participants
m0ebius604
2017+ Chrysler Pacifica Minivan Forums
PacificaForums.com - A forum community dedicated to Chrysler Pacifica owners & enthusiasts. Come join the discussion about upgrades, towing capacity, reliability, and more!
Full Forum Listing
Top