2017+ Chrysler Pacifica Minivan Forums banner

1 - 20 of 35 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I bought new 2018 Pacifica Hybrid just 2 days back. I have following problems so far

1) Assist button on the mirror doesn't work. When I press that button, I get a message on the scree "Please wait..." and it is on for ever.

2) The Media USB port doesn't charge my phone. Even Apply play Icon doesn't show up when I plug-in my phone in the usb port

Lately today, with just 150 miles

3) "Check Engine light" is ON. Anyone has similar problem ?

With these many problems with-in 2 days, wondering if I made a good choice buying this car.
 

·
Registered
Joined
·
162 Posts
I would go and sign up for the 1) Sirius and 2) Uconnect and 3) mopar account. Do these online first if you havn't done so, here is the FAQ:

https://www.driveuconnect.com/faq.html

https://www.driveuconnect.com/sirius-xm-guardian.html

Put your VIN in here and see if its needs an update, which is unlikely, but check:

https://www.driveuconnect.com/support/software-update.html

Actually, try this first: Go in to Uconnect in the van and press the "Clear Personal Data". Then see if the Assist button works. If it does start the registration.

If not call the number and give them your VIN and tell them it isn't working., also found at the link above. But before calling I would be signed up with a Mopar account and have the app set up at a min.

I think the sites are updating right now so I am not sure if you can register at this second.

I would start with the mopar account right away, I believe that may link you to the Uconnet and Sirius Guardian stuff. Also put the Uconnect app on your phone. Even if it doesn't work once you are in those systems then it's simpler for the person on the phone to assist you, the VIN and your vehicle will be there for them. I know the most current for android but not sure of the most current app for Iphone.

https://www.mopar.com/chrysler/en-us/sign-in.html
 

·
Registered
Joined
·
1,629 Posts
I bought new 2018 Pacifica Hybrid just 2 days back. I have following problems so far

1) Assist button on the mirror doesn't work. When I press that button, I get a message on the scree "Please wait..." and it is on for ever.

2) The Media USB port doesn't charge my phone. Even Apply play Icon doesn't show up when I plug-in my phone in the usb port

Lately today, with just 150 miles

3) "Check Engine light" is ON. Anyone has similar problem ?

With these many problems with-in 2 days, wondering if I made a good choice buying this car.
I don't have a hybrid, but you can try the search bar or the forum tab and then hybrids. It seems like there have been posts on these things already. Don't assume that the dealer set things up for you with UConnect or Guardian or whatever the 2018 version is. I think I ended up registering with a laptop and/or phone sitting in the van. Go to the website in the multimedia manuals or the Chrysler website. Did you try the other USB ports to see if they charge the phone? Do you have access to the online manuals? If not here are a couple of links to try:

http://redirect.viglink.com/?format=go&jsonp=vglnk_152782452544213&key=7dad9a203d07e2eb47c055db7f7aaaf8&libId=jhvf9jaw01013vc4000DA8d4v0486&loc=http://www.pacificaforums.com/forum/193-2017-chrysler-pacifica-minivan-general-discussion/21313-2018-owners-manual-link.html&v=1&out=https://www.mopar.com/moparsvc/tweddle/publications?id=9112&ref=http://www.pacificaforums.com/forum/gtsearch.php?q=2018%20manual%20uconnect&title=2018 Owners Manual Link - 2017+ Chrysler Pacifica Minivan Forums&txt=https://www.mopar.com/moparsvc/twedd...ations?id=9112
https://www.chrysler.com/uconnect.html#2018-chrysler-pacifica_hybrid
 

·
Registered
Joined
·
685 Posts
For the Check Engine on - I would recommend you to get one of those ODBII Readers. You can buy some very cheap that works with your phone. The point is to have the code of the error and what's all about before you go to your dealer or any dealer. You are currently under warranty but it's better to be informed before you go to a dealer. At least you can have an idea of their honesty level.
 

·
Registered
Joined
·
30 Posts
For the Assist function not working it has to go in for service. There are several STAR cases documenting this problem. The dealer has to do a hard reboot of the system to get it working. Doesn't seem like a big deal for them to fix once they understand the problem and contact Chrysler. I don't think there's a conspiracy to keep fault codes a secret, no need to buy an OBDII reader, just have them check it when you take it in to have the Assist/Guardian features fixed. My family loves our vehicle.
 

·
Registered
Joined
·
685 Posts
For the Assist function not working it has to go in for service. There are several STAR cases documenting this problem. The dealer has to do a hard reboot of the system to get it working. Doesn't seem like a big deal for them to fix once they understand the problem and contact Chrysler. I don't think there's a conspiracy to keep fault codes a secret, no need to buy an OBDII reader, just have them check it when you take it in to have the Assist/Guardian features fixed. My family loves our vehicle.
It's not about conspiracy it's the fact that has been documented many times on Internet where you get the light, you have the reader and you learn what the code means and when you go to the dealer or your mechanic they tell you something different specially if you have to pay from your pocket.
$20 or $30 dollars invested can save you a lot down the road. In this case he still under warranty so I would do it just for the heck of checking if they are telling you the real thing.
 

·
Registered
Joined
·
158 Posts
I had a (self-created) problem with the CarPlay icon not showing up. In ther mirror cast settings there is an option to enable/disable CarPlay. Sorry I can't remember the exact verbiage and am not near the van.
 

·
Registered
Joined
·
2,099 Posts
I bought new 2018 Pacifica Hybrid just 2 days back. I have following problems so far

1) Assist button on the mirror doesn't work. When I press that button, I get a message on the scree "Please wait..." and it is on for ever.

2) The Media USB port doesn't charge my phone. Even Apply play Icon doesn't show up when I plug-in my phone in the usb port

Lately today, with just 150 miles

3) "Check Engine light" is ON. Anyone has similar problem ?

With these many problems with-in 2 days, wondering if I made a good choice buying this car.
You've got some great advice here, ravicanth. When you take your Pacifica back into the dealer, feel free to let us know. We're available via direct message and can get this over to a Case Specialist for further handling.

Jasmine
Chrysler Social Care Specialist
 

·
Registered
Joined
·
30 Posts
As a follow up to taking your car in for service to fix the Assist button not working: you won't be able to sign up for the Guardian service which triggers the Uconnect app connection and all the services that comes with that. Don't waste your time running around in circles with Guardian/Sirius/Mopar tech support on the phone. The dealership reset of the software is the only thing that will get it working. Also worth mentioning that the SOS button is also tied in with this fix.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Left the car with dealership since last 4 days. Still they have no clue what was wrong. Hopefully they can identify, fix and return my van quickly. I got an impression that enough training was not given to the service technicians to addresses these kind of problems. This is a great van with very good features, but employees are not trained enough to address these kind of problems. And also I am not sure what kind of quality checks Chrysler has. For the brand new car, some of the features doesn't work from day one. Do they release these cars to market without proper quality checks ?
 

·
Registered
Joined
·
2,099 Posts
Left the car with dealership since last 4 days. Still they have no clue what was wrong. HWopefully they can identify, fix and return my van quickly. I got an impression that enough training was not given to the service technicians to addresses these kind of problems. This is a great van with very good features, but employees are not trained enough to address these kind of problems. And also I am not sure what kind of quality checks Chrysler has. For the brand new car, some of the features doesn't work from day one. Do they release these cars to market without proper quality checks ?
We're terribly sorry to hear you're continuing to have trouble. Do you know if they get STAR involved? Send me a direct message as I'd be glad to discuss this in more detail and help however I can.

Jasmine
Chrysler Social Care Specialist
 

·
Registered
Joined
·
30 Posts
Communication breakdown somewhere. The problem is well known by STAR, as is the solution. The simplest way to explain to the service department is, "The assist button on the rear view mirror does not work, it goes into an infinite "please wait loop" when pressed" Show them. Don't worry about anything else. If the dealership contacts STAR with that complaint, the dealership will get instructions on how to fix it and you'll be on your way. No parts required, just a hard reboot of the system.
 

·
Registered
Joined
·
1 Posts
check engine light.

We've had our 2018 plug-in pacifica since February and the check hybrid engine came on 2 days after purchase. Just got it back after 3rd time in the shop, this time for 20 days, for same issue. They called and said it's a "known issue" and "will happen again". They said there's a bubble in the coolant line and they had to bleed the line. [I'm leaving out all my personal complaints about this Chrsyler service location and sticking to facts.] I'm on this forum now looking for something to back up his statement that it's a common problem, before I call Chrysler and the Attorney General.
 

·
Registered
Joined
·
9 Posts
I also had the engine light go on in my 2018 hybrid a few weeks ago, took it to the dealer and they also said something about coolant. They said that there actually was not a problem with the coolant and I didn't understand the rest of the explanation (I'm a lawyer).

Since then the light went on again for about a day last week and went off again. Will be keeping an eye on it, of course.
 

·
Registered
Joined
·
2,099 Posts
We've had our 2018 plug-in pacifica since February and the check hybrid engine came on 2 days after purchase. Just got it back after 3rd time in the shop, this time for 20 days, for same issue. They called and said it's a "known issue" and "will happen again". They said there's a bubble in the coolant line and they had to bleed the line. [I'm leaving out all my personal complaints about this Chrsyler service location and sticking to facts.] I'm on this forum now looking for something to back up his statement that it's a common problem, before I call Chrysler and the Attorney General.
Hi iggyaa,

I am unable to provide any technical advice. However, if you want to maybe get a second opinion, I can help with that process by escalating to a Case Specialist for further handling. I am available via direct message if this is of interest.

Jasmine
Chrysler Social Care Specialist
 

·
Registered
Joined
·
4 Posts
We have the same experience with check engine light. It comes on all the time without reason. On for about a week or two then off for a week. This car was a horrible mistake.
 

·
Registered
Joined
·
1 Posts
I bought 2018 Pacifica Hybrid two weeks ago. Yesterday, my screen went completely blank. I tried everything but it would not work. Today the screen works but the engine sign is on. I will have to drive to the dealer to have it checked tomorrow. After reading the posts, I am starting to regret my decision of buying that car. I ave only had it for two weeks , i do not even drive it that much because i work from home and I already have multiple issues with the car. I do not ave time to go to the dealer every week.
I just sold my old car which I had for 11 years, the only issue I had with it was tires that would wear now and then out.... But that was Cadillac.
 

·
Registered
Joined
·
2 Posts
I have a check engine light and I went to auto zone to find out the code because they check it for free and their reader didn’t capture any codes... is this a false alarm or their reader is low quality? Ideas? I have an appointment but not for another 5 days and I need the car.
 
1 - 20 of 35 Posts
Top