2017+ Chrysler Pacifica Minivan Forums banner
61 - 65 of 65 Posts

·
Registered
Joined
·
23 Posts
So indy replaced strut (back-ordered no aftermarket part so it's a complete ripoff) and strut mount and noise is still there. Going to try to source a front lower control arm as that appears to be complained about a lot. If that doesn't work, I'm at wits end.
 

·
Registered
Joined
·
3 Posts
So indy replaced strut (back-ordered no aftermarket part so it's a complete ripoff) and strut mount and noise is still there. Going to try to source a front lower control arm as that appears to be complained about a lot. If that doesn't work, I'm at wits end.
Had this problem on my 2018 Pacifica. Try replacing the front sway bar end links. I ordered some aftermarket HD ones from Rockauto that have grease fittings. MOOG I believe. Problem solved. The OE don’t seem worn but must have been.
 

·
Registered
Joined
·
23 Posts
Just got word that the replacement lower control arm did the trick and the van is now fixed. Woo hoo.
 

·
Registered
Joined
·
4 Posts
Hi Springster,
We are sorry to hear that you have been experiencing this. Has a case been opened on the customer care side to assist in addressing your concern? If not, please send our team a private message and we would be happy to get this process started for you!
Alex
Chrysler Social Care Specialist
Hi.
Hi, just wondering... Was there ever a final resolution for this issue?
I have a 2017 with almost 50,000 miles... I started hearing a loud popping sound when slowly backing-up while turning wheels to the left and then straight... just dropped off at dealer and they said it's the strut on the driver's side, but will take 1 to 2 weeks for parts.
 

·
Registered
Joined
·
4 Posts
I noticed this same issue on my wife’s 2018 (32K miles) last week when I drove it. Sounds like a bad strut to me. Going to have them take a look next time I’m in for an oil change and/or rotation.
Hi, just wondering... Was there ever a final resolution for this issue?
I have a 2017 with almost 50,000 miles... I started hearing a loud popping sound when slowly backing-up while turning wheels to the left and then straight... just dropped off at dealer and they said it's the strut on the driver's side, but will take 1 to 2 weeks for parts.
 
61 - 65 of 65 Posts
Top