2017+ Chrysler Pacifica Minivan Forums banner
61 - 78 of 78 Posts

·
Registered
Joined
·
23 Posts
So indy replaced strut (back-ordered no aftermarket part so it's a complete ripoff) and strut mount and noise is still there. Going to try to source a front lower control arm as that appears to be complained about a lot. If that doesn't work, I'm at wits end.
 

·
Registered
Joined
·
3 Posts
So indy replaced strut (back-ordered no aftermarket part so it's a complete ripoff) and strut mount and noise is still there. Going to try to source a front lower control arm as that appears to be complained about a lot. If that doesn't work, I'm at wits end.
Had this problem on my 2018 Pacifica. Try replacing the front sway bar end links. I ordered some aftermarket HD ones from Rockauto that have grease fittings. MOOG I believe. Problem solved. The OE don’t seem worn but must have been.
 

·
Registered
Joined
·
23 Posts
Just got word that the replacement lower control arm did the trick and the van is now fixed. Woo hoo.
 

·
Registered
Joined
·
10 Posts
Hi Springster,
We are sorry to hear that you have been experiencing this. Has a case been opened on the customer care side to assist in addressing your concern? If not, please send our team a private message and we would be happy to get this process started for you!
Alex
Chrysler Social Care Specialist
Hi.
Hi, just wondering... Was there ever a final resolution for this issue?
I have a 2017 with almost 50,000 miles... I started hearing a loud popping sound when slowly backing-up while turning wheels to the left and then straight... just dropped off at dealer and they said it's the strut on the driver's side, but will take 1 to 2 weeks for parts.
 

·
Registered
Joined
·
10 Posts
I noticed this same issue on my wife’s 2018 (32K miles) last week when I drove it. Sounds like a bad strut to me. Going to have them take a look next time I’m in for an oil change and/or rotation.
Hi, just wondering... Was there ever a final resolution for this issue?
I have a 2017 with almost 50,000 miles... I started hearing a loud popping sound when slowly backing-up while turning wheels to the left and then straight... just dropped off at dealer and they said it's the strut on the driver's side, but will take 1 to 2 weeks for parts.
 

·
Registered
Joined
·
2,874 Posts
Hi.
Hi, just wondering... Was there ever a final resolution for this issue?
I have a 2017 with almost 50,000 miles... I started hearing a loud popping sound when slowly backing-up while turning wheels to the left and then straight... just dropped off at dealer and they said it's the strut on the driver's side, but will take 1 to 2 weeks for parts.
Hello @DPHPacifica,
Thank you for reaching out to us. Has the dealer received the required parts? If not please feel free to follow up with us privately.

Lamar
Chrysler Cares
 

·
Registered
Joined
·
10 Posts
Hello @DPHPacifica,
Thank you for reaching out to us. Has the dealer received the required parts? If not please feel free to follow up with us privately.

Lamar
Chrysler Cares
Hi Lamar. Originally, the dealer was going to replace the struts and mounts on both sides, but... because i had puchased the lifetime warranty, they said they only needed to replace the front mount on driver's side, which seemed to be the source of the noise! We dropped the car at dealer this AM, and was just told they are finished. So, i will go this afternoon to pickup the car and will update this post, Good or Bad. Thanks.
 

·
Registered
Joined
·
10 Posts
Hi Lamar. Originally, the dealer was going to replace the struts and mounts on both sides, but... because i had puchased the lifetime warranty, they said they only needed to replace the front mount on driver's side, which seemed to be the source of the noise! We dropped the car at dealer this AM, and was just told they are finished. So, i will go this afternoon to pickup the car and will update this post, Good or Bad. Thanks.
Status Update: The "fix" for my 2017 Pacifica, with 50k miles, was to replace [just] the mount for the Left-front strut. Loud "popping sound" was immediately resolved. So, i guess time will tell whether this is/was a permanent resolution, and whether the Right-front mount will also need to be replaced! For now...so far, so good!
 

·
Registered
Joined
·
17 Posts
Our 2020 Hybrid Touring Pacifica has a click/clunk sound in the front end noticeable at parking lot speeds, with each acceleration and slowing. It isn't a particular loud, or alarming(damaging) sound. Sounds like play in the drive train to me, but can imagine a suspension, or a 'top of the strut' issue as some of the posts have suggested. I had it in for service, don't know what was done specifically, but it involved new nuts that holds each front wheel on the axel (Not the lug nuts). Seemed to be fixed, but 500 miles later the noise is back. Posting for additional feedback before I go back the dealer. Thank you.
 

·
Banned
Joined
·
1,471 Posts
Our 2020 Hybrid Touring Pacifica has a click/clunk sound in the front end noticeable at parking lot speeds, with each acceleration and slowing. It isn't a particular loud, or alarming(damaging) sound. Sounds like play in the drive train to me, but can imagine a suspension, or a 'top of the strut' issue as some of the posts have suggested. I had it in for service, don't know what was done specifically, but it involved new nuts that holds each front wheel on the axel (Not the lug nuts). Seemed to be fixed, but 500 miles later the noise is back. Posting for additional feedback before I go back the dealer. Thank you.
You need the actual strut replaced. Anything else would just be a partial measure that won’t last.
 

·
Registered
Joined
·
65 Posts
Status Update: The "fix" for my 2017 Pacifica, with 50k miles, was to replace [just] the mount for the Left-front strut. Loud "popping sound" was immediately resolved. So, i guess time will tell whether this is/was a permanent resolution, and whether the Right-front mount will also need to be replaced! For now...so far, so good!
I'm currently on my 7th "bad" strut :) Just got mine out of the shop when they replaced both front struts and mounts and I'm hearing the noises I know now are precursors to the knocking.
 

·
Banned
Joined
·
1,471 Posts
I just got back from a business trip and was driving the Pacifica around today taking stuff to the dump, etc. Clunking has gotten REALLY bad...
 

·
Banned
Joined
·
1,471 Posts

·
Banned
Joined
·
1,471 Posts
Put it in today. Miraculously they had a Pacifica loaner for me. They figure they will have it until at least Friday.
 

·
Registered
Joined
·
65 Posts
Put it in today. Miraculously they had a Pacifica loaner for me. They figure they will have it until at least Friday.
Lucky dog! Good for you though, glad they had the loner available. Parts just came in today for mine. This will be the 4th repair attempt and they are replacing all front end suspension components. Have an open lemon law case in Texas, so this will be their final attempt.
 

·
Banned
Joined
·
1,471 Posts
So, according to them the clunk was caused by "the accessory battery not being connected and just clunking around in there"... unfortunately I was out of pocket all day and my wife picked it up. I will drive it over the next few days and see if the clunking is gone, but my guess is its not.

My driver side rear seat also was jammed so that it wouldn't tilt forward for access to the third row. That was caused by "the cable not being connected and it jamming in the mechanism". Good ol Chrysler.
 
61 - 78 of 78 Posts
Top