2017+ Chrysler Pacifica Minivan Forums banner

1 - 20 of 153 Posts

·
Registered
Joined
·
325 Posts
Discussion Starter #1
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
 

·
Registered
Joined
·
2,317 Posts
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
Hi ezdays,

Sorry to hear about this! I'd be happy to follow up with your dealership for you if needed, just PM our page with your VIN and let me know.

Andrea
Chrysler Social Care Specialist
 

·
Registered
Joined
·
325 Posts
Discussion Starter #4
If it happens again, hold in the Mute and Tune buttons together for about 5 seconds. That will reboot the Uconnect system.
Thanks, I'll try that if it happens again.

Hi ezdays,

Sorry to hear about this! I'd be happy to follow up with your dealership for you if needed, just PM our page with your VIN and let me know.

Andrea
Chrysler Social Care Specialist
Thanks Andrea, I'll do that if it continues to happen, but I'll try generaltso's advice first to see what that does.... It only happened the one time, a reboot is a lot easier than a trip to the dealer...
 

·
Registered
Joined
·
2 Posts
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
I got on here to see if anyone else had this issue!!! This has happened to me now FOUR TIMES and I've only had my van for a month. I've never wanted to scream so much. Four kids in the back wanting their movie sound on and there was literally nothing I could do. I did like you and turned it off & on, I tried going through voice control but as soon as I'd try hitting a button on the screen it would go back to climate!? I keep saying, if it happens again, I'll go to the dealer. I just don't have time! I'm really praying this magic reset solution works next time!

If it happens again, hold in the Mute and Tune buttons together for about 5 seconds. That will reboot the Uconnect system.
Thank you for this!!!! I really hope this works next time! I'm not in the van now but are both of those buttons hard buttons on the panel?
 

·
Super Moderator
Joined
·
2,884 Posts
Thank you for this!!!! I really hope this works next time! I'm not in the van now but are both of those buttons hard buttons on the panel?
Yes, they are the buttons in this middle of the volume and tune knobs.
 

·
Registered
Joined
·
1,002 Posts
This morning we went out and everything was normal. I had the climate screen on so we could turn on the seat heaters. On the way back, nothing on the screen would work, I couldn't change screens and worst of all, I couldn't turn on the heated seats. The touch screen was locked where I couldn't change anything, except if I used one of the manual controls, it would reflect that. I turned the ignition off and restarted, but it still refused to allow me to change anything, even turning the screen off and on again didn't help. I got home, and the next time we turned the engine on, about a half-hour later, everything was working again. I haven't a clue why this happened, it's the first time it did.

Just wondering, has anyone else experienced this? I was planning a trip to the dealer, but now that it works, that would be a waste of time.
I suggest turning the defrost on to thaw out your screen. :grin2:
 

·
Registered
Joined
·
3 Posts
I also have a month old Pacifica 2017 and I am having the same problem. I has happened to me 5 or 6 times and I have learned to stop, turn off the car, and open my door to truly shut everything off. Found that you need to sit for at least 3 to 5 minutes before restarting. So far this has corrected the problem for the rest of the day at least. The problem so far generally only occurs on the first start up of the day and once fixed has not reoccurred again the same day. I'm not looking forward to a dealer visit unless I should have the screen frozen and will not shut off the engine until I am at the dealer and have shown them the problem. Doubt they will be all that impressed if they shut down like I do and everything then works fine.
 

·
Registered
Joined
·
3 Posts
2017 Chrysler Pacifica Frozen Touch Pad

Picked up my Pacifica one month ago and this screen has frozen on me 5 or 6 times. Really a pain. I think I rebooted UConnect as others have suggested but without effect. I have found that if I stop, shut off the car, even open my door to fully remove energy from this system and then wait 3-5 minutes, it will come up and work fine. If I immediately restart, it can stay frozen. This seems to happen to me usually on the first engine start up of the day and once corrected as above, everything works fine the rest of the day.
Will only go to the dealer if I get a frozen screen and can take to the dealer without shutting off the car, but doubt they will be impressed if they shut the car off, restart and everything works.
Wondered if you are still having the problem and is so did Chrysler respond and if so how??
 

·
Registered
Joined
·
5 Posts
2017 Pacifica screen freeze

I got my 2017 Touring L van in January and the screen freeze issue began happening every few weeks. It resolves when I completely shut down the van and restart later in the day. I took it to the dealer and they had no solution because I could not reproduce the problem for them to see. Now the same issue is more frequent, up to 3 times per week. I reported it to Chrysler by email and the Uconnect tech support agreed to document the problem. Their only suggestion is to go back to the dealership to see if the problem can be reproduced. This is a waste of time since they have no service bulletin for the issue and know nothing about Uconnect software. I have checked and so far there is no software update available for the Pacifica. The reset method described in this thread does seem to work for now. Everyone who experiences the issue should complain to Chrysler until they eventually fix the problem. The van is otherwise very enjoyable to drive so let's hope they fix this soon.
 

·
Registered
Joined
·
104 Posts
I've encountered this issue before too just as you describe
 

·
Registered
Joined
·
11 Posts
Overall, I love my Pacifica.

My Pacifica was built in ~June 2017. I've had it for 2 months now, and I have had the frozen touch screen issue happen 3 times already.

I'm not sure when the freeze occurs, but I think it's right around engine start time. I don't think it happens at a random time during a drive.

The freeze does not affect the car's functioning, and the screen otherwise continues to operate normally (it updates if you use the buttons to change the temperature, or fan speed; it activates the camera if you shift into reverse).

It's just that the screen is completely unresponsive. I tried resetting the system by holding the Mute and Volume buttons. The system did reset, but this did not fix the condition. Tried again, still no luck. The screen returned to displaying what was there before the reboot. The situation only returned to normal when I reached my destination and shut off/exited the vehicle and came back to it later (~20 minutes).


I don't want to bring it to the dealer yet since (1) How would they be able to reproduce the problem? (2) I don't want to lose the vehicle for 1+ days; and (3) since this is a new car, and apparently a common problem, I don't know that the new screen won't develop this issue.

Finally, for those who did go for a screen replacement: how well do the service guys install the new screen? Does it look new or does it look repaired?

Any chance this could one day be solved by a software fix?
 

·
Registered
Joined
·
86 Posts
Overall, I love my Pacifica.

My Pacifica was built in ~June 2017. I've had it for 2 months now, and I have had the frozen touch screen issue happen 3 times already.

I'm not sure when the freeze occurs, but I think it's right around engine start time. I don't think it happens at a random time during a drive.

The freeze does not affect the car's functioning, and the screen otherwise continues to operate normally (it updates if you use the buttons to change the temperature, or fan speed; it activates the camera if you shift into reverse).

It's just that the screen is completely unresponsive. I tried resetting the system by holding the Mute and Volume buttons. The system did reset, but this did not fix the condition. Tried again, still no luck. The screen returned to displaying what was there before the reboot. The situation only returned to normal when I reached my destination and shut off/exited the vehicle and came back to it later (~20 minutes).


I don't want to bring it to the dealer yet since (1) How would they be able to reproduce the problem? (2) I don't want to lose the vehicle for 1+ days; and (3) since this is a new car, and apparently a common problem, I don't know that the new screen won't develop this issue.

Finally, for those who did go for a screen replacement: how well do the service guys install the new screen? Does it look new or does it look repaired?

Any chance this could one day be solved by a software fix?
I have only had my Hybrid for a week now and the unit had malfunctioned at least a half dozen times. I?ve started recording videos of my issues because odds are a day off and trip to the dealer will come up inconclusive. I have also had intermittent luck with reseting via the power and mute button. I expected some hiccups, but I am very disappointed as well and fear a software update will not resolve the issue. My guess this is a memory/hardware issue.

Once the dealer eventually calls me to schedule my due bill related items I plan to address these issues.
 

·
Registered
Joined
·
11 Posts
I have had a very similar problem twice since I bought my Touring L in June.

The only difference is that instead of being totally unresponsive, if you touch the screen anywhere it just jumps to the media section on whatever option I was last using (Bluetooth or USB). Quick on/off doesn't seem to fix it, car has to be shut down for a couple of minutes before it corrects itself.

I'm having a similar thoughts as you - I can't recreate this so taking it to a dealer would be likely fruitless.

I guess the only thing to do is take the car to a dealer while it's happening and show the techs without turning the car off. Hard to schedule that though, and even then if you can't turn the car off to run diagnostics it might be difficult for them to figure it out.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,317 Posts
I have had a very similar problem twice since I bought my Touring L in June.

The only difference is that instead of being totally unresponsive, if you touch the screen anywhere it just jumps to the media section on whatever option I was last using (Bluetooth or USB). Quick on/off doesn't seem to fix it, car has to be shut down for a couple of minutes before it corrects itself.

I'm having a similar thoughts as you - I can't recreate this so taking it to a dealer would be likely fruitless.

I guess the only thing to do is take the car to a dealer while it's happening and show the techs without turning the car off. Hard to schedule that though, and even then if you can't turn the car off to run diagnostics it might be difficult for them to figure it out.


Sent from my iPhone using Tapatalk
Hi Bryancain,

There is currently an Over the Air software update being rolled out across the United States to qualifying vehicles. We would recommend performing the update when it appears on your Uconnect screen and seeing if this fixes your concerns, if it doesn't please send us a PM with your VIN so I can investigate further for you!

Andrea
Chrysler Social Care Specialist
 

·
Registered
Joined
·
11 Posts
Hi Bryancain,

There is currently an Over the Air software update being rolled out across the United States to qualifying vehicles. We would recommend performing the update when it appears on your Uconnect screen and seeing if this fixes your concerns, if it doesn't please send us a PM with your VIN so I can investigate further for you!

Andrea
Chrysler Social Care Specialist
Thanks! Is there a way to force the car to check for updates, or do I just have to wait?
 

·
Registered
Joined
·
2,317 Posts
I have only had my Hybrid for a week now and the unit had malfunctioned at least a half dozen times. I?ve started recording videos of my issues because odds are a day off and trip to the dealer will come up inconclusive. I have also had intermittent luck with reseting via the power and mute button. I expected some hiccups, but I am very disappointed as well and fear a software update will not resolve the issue. My guess this is a memory/hardware issue.

Once the dealer eventually calls me to schedule my due bill related items I plan to address these issues.
Hi JMcMillan,

As I recommended to @Bryancain there is currently an Over the Air software update being rolled out across the United States to qualifying vehicles. We would recommend performing the update when it appears on your Uconnect screen and seeing if this fixes your concerns, if it doesn't please send us a PM with your VIN so I can investigate further for you!

Andrea
Chrysler Social Care Specialist
 
1 - 20 of 153 Posts
Top