2017+ Chrysler Pacifica Minivan Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
The display on the Uconnect system is just showing garbage, best way to describe it is it looks like a giant barcode. The touch portion still seems to be working since it changes the radio station and stuff if you touch it. Any way I can soft or hard reset the thing? It's Saturday night so I can't just drive down the dealer until Monday at the earliest.
 

·
Registered
Joined
·
758 Posts
SOFT RESET OF UCONNECT

"Step 1) Put your vehicle into the accessories mode (ACC or RUN) **For keyless start (push-button) vehicles: push the start button twice without having your foot on the gas or brake pedal**
Step 2) Hold down the volume and tuner knob buttons, at the same time, for thirty seconds (or until the screen goes black and restarts).
Step 3) Let go of the buttons
Step 4) Turn vehicle off
Step 5) Open driver’s side door for thirty seconds
Step 6) Close door
Step 7) Restart vehicle
Step 8) Let the media centre load up and see if concern is still present"
 

·
Registered
Joined
·
2,474 Posts
The display on the Uconnect system is just showing garbage, best way to describe it is it looks like a giant barcode. The touch portion still seems to be working since it changes the radio station and stuff if you touch it. Any way I can soft or hard reset the thing? It's Saturday night so I can't just drive down the dealer until Monday at the earliest.
Hi needforspeed,

Sorry to hear about this! If you decide to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just PM our page with your VIN and let me know.

Andrea
Chrysler Social Care Specialist
 

·
Registered
Joined
·
171 Posts
The reset directions below don't seem to work on my 2018 with the UConnect 4C that has an On/Off button where there used to be a mute button (in the middle of the volume knob). If I hold those two buttons down, the display goes blank as it does when you hit the on/off button alone.

My Streaming WiFi for UConnect Steaming no longer works, so I was hoping to give it a soft reboot to see if I got any improvement.
 

·
Registered
Joined
·
758 Posts
The reset directions below don't seem to work on my 2018 with the UConnect 4C that has an On/Off button where there used to be a mute button (in the middle of the volume knob). If I hold those two buttons down, the display goes blank as it does when you hit the on/off button alone.

My Streaming WiFi for UConnect Steaming no longer works, so I was hoping to give it a soft reboot to see if I got any improvement.
Maybe on the 2018s it is the mute button and the tuner button to reset and not the volume knob. Did you try that combo?
 

·
Registered
Joined
·
171 Posts
Maybe on the 2018s it is the mute button and the tuner button to reset and not the volume knob. Did you try that combo?
It's funny you suggest that. Yes, that was the next thing I did. I also followed a recommendation to hold down the up and down arrows for the driver's side climate control, which apparently worked on older UConnect models, but didn't work here.

I would happily buy the shop (service) manuals, but I can only find 2017 service manuals that will not have detail for the new 2018 radios.
 

·
Registered
Joined
·
1,144 Posts
This is what I got from the Facebook group:

Hold phone button (touch screen) and voice recognition button (steering wheel) both at the same time for 30 seconds while vehicle is running. Turn car off. Open driver door 30 seconds. Close door. Turn car on.
 

·
Registered
Joined
·
7 Posts
This is what I got from the Facebook group:

Hold phone button (touch screen) and voice recognition button (steering wheel) both at the same time for 30 seconds while vehicle is running. Turn car off. Open driver door 30 seconds. Close door. Turn car on.
That might work if my touch screen was responding to touch.
 
S

·
Guest
Joined
·
0 Posts
I felt like the only thing I didn't have to do was. the "hokey pokey" but FFS it worked!!! Thank you sooo much. Suzanne
 

·
Registered
Joined
·
1 Posts
Hi Chrysler cares. I bought a 2-019 jeep grand Cherokee. the radio does not want to control my ipod. after moving to a diff jeep on the lot, every thing worked, so its obviously not the ipod but the jeep itself. BTW it never worked from day 1. Finally after 5 trip to the dealers and untold number of calls to Chrysler engineers they put a new radio in. it worked for 2 weeks. that's it. Nothing was done to the ipod it wasn't updated changed or anything else. In fact I wasn't even home, I was away on business, and the truck wasn't being driven.


Please help!!!
 

·
Registered
Joined
·
210 Posts
Hi Chrysler cares. I bought a 2-019 jeep grand Cherokee. the radio does not want to control my ipod. after moving to a diff jeep on the lot, every thing worked, so its obviously not the ipod but the jeep itself. BTW it never worked from day 1. Finally after 5 trip to the dealers and untold number of calls to Chrysler engineers they put a new radio in. it worked for 2 weeks. that's it. Nothing was done to the ipod it wasn't updated changed or anything else. In fact I wasn't even home, I was away on business, and the truck wasn't being driven.





Please help!!!
1. Chrysler Cares doesn't provide tech support, they just direct you to the dealer for any problems or questions. 2. This is the 2017+ Chrysler Pacifica minivan forum, so while your Grand Cherokee may have a similar infotainment system, technically it's off-topic and you might have better luck from a Jeep Grand Cherokee forum.
 

·
Registered
Joined
·
2,474 Posts
Hi Chrysler cares. I bought a 2-019 jeep grand Cherokee. the radio does not want to control my ipod. after moving to a diff jeep on the lot, every thing worked, so its obviously not the ipod but the jeep itself. BTW it never worked from day 1. Finally after 5 trip to the dealers and untold number of calls to Chrysler engineers they put a new radio in. it worked for 2 weeks. that's it. Nothing was done to the ipod it wasn't updated changed or anything else. In fact I wasn't even home, I was away on business, and the truck wasn't being driven.


Please help!!!
Hi mmaturi,
We understand why this may be frustrating. Feel free to send our team a private message and we would be happy to look into this further for you!
Alex
Chrysler Social Care Specialist
 

·
Registered
Joined
·
686 Posts
Remove Fuse 76 for few seconds and put it back.
 
1 - 14 of 14 Posts
Top