2017+ Chrysler Pacifica Minivan Forums banner

261 - 280 of 307 Posts

·
Registered
Joined
·
43 Posts
So I have a 2017 that I upgraded to a 2018 UAV. It is working well though I lost the built in navigation. I have done only around 15K miles in 3 years, so don't feel like buying a new one. What are the chances that the 2021 uConnect 5 would work on the 2017 ? I would love the larger display and wireless carplay.
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
So I have a 2017 that I upgraded to a 2018 UAV. It is working well though I lost the built in navigation. I have done only around 15K miles in 3 years, so don't feel like buying a new one. What are the chances that the 2021 uConnect 5 would work on the 2017 ? I would love the larger display and wireless carplay.
[/QUOTE
Also interested to find this out. Though, until some used units become available, it could be very expensive to do ! New receiver module I expect and def new screen and bezel. I want to switch out my tail lights for the 2021 set up also , Just waiting for a few 2021's to be wrecked and parts put on eBay !!!
 

·
Registered
Joined
·
13 Posts
I ordered from them as well....🤦‍♂️...mine should be here next week, I’ll keep you guys posted.

thanks
they messed up the paperwork and it never got through customs. 🙄 Can anyone confirm they have the 2020 system working in 2017? seems only marketmaster tried and it didn't work for him. 2018s are more available but i thought it be better to get something newer software
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
they messed up the paperwork and it never got through customs. 🙄 Can anyone confirm they have the 2020 system working in 2017? seems only marketmaster tried and it didn't work for him. 2018s are more available but i thought it be better to get something newer software
I used a unit from a 2019 and it works fine.
 

·
Registered
Joined
·
4 Posts
Hi everyone, Thanks for all the inputs from all the wonderful people on this thread. I am just summarizing useful info from this thread in case a newbie like me tries to do this and does not have the patience to read through all the pages on this thread.


I ended up buying the kit from infotainment for the 2017 pacifica carplay upgrade. Installed it yesterday myself and pretty happy with it. You could also buy the parts from ebay or OEM Mopar parts and it could be cheaper. But returning and also activating the radio/navigation etc could be painful. I decided to pay extra and have some customer service support if things didn't work.


If you decide to not get the kit from infotainment, You need 3 things to do the install:
The screen part number is 68316174AB . This is the same part number for 2018 and 2019 models.
https://www.moparamerica.com/.../mopar-center-stack...
The processing unit : 68351931AH . The latest part is 68429204AC which overrides the part needed.
https://www.moparamerica.com/.../mopar-multi-media-radio...
New Video cable to connect the processing unit to the new display:
https://www.ebay.com/itm/FAKRA-Z-HSD-Video-Cable-Retrofit-Cable-Shielded-Dacar-535-4-Core-50cm-for-BMW/173947071289?hash=item28800dab39:g:rC4AAOSwHItdFYSq

If you decide to use junkyard parts, You can use Car-Part.com--Used Auto Parts Market or search for the part numbers in ebay.

Once I did the install and turned on the car. The backup camera, audio did not work so it really spooked me. But I waited for an hour (The new parts need to sync with the central computer in the car), and everything worked including carplay/navigation. There are no installation instructions, The cables are colored and you need to insert them into the right color. The orange cable in your current car unit does not go into the new unit, and the red/purple and small black input in the new unit stay empty (they are together). If anyone on the group tries to do this and hits any issues, Please feel free to reach out to me. See page2 of this thread where there are some pictures posted on how the new and old processing unit look. Make sure you use the new video cable to connect the processing unit to the display. The space is really tight and the cables are little hard to pull out, So be patient and don't try to rush. It took me an hour :).


If you end up getting used car parts Or OEM mopar parts and need to unlock the radio:
https://www.ebay.com/itm/CHRYSLER-RADIO-PIN-CODE-DECODE-UNLOCK-CRUISER-VOYAGER-300-PACIFICA-EXPERT-200/153864839065?hash=item23d30f1f99:g:FN4AAOSwQC9ebSLP
 

·
Registered
Joined
·
4 Posts
they messed up the paperwork and it never got through customs. 🙄 Can anyone confirm they have the 2020 system working in 2017? seems only marketmaster tried and it didn't work for him. 2018s are more available but i thought it be better to get something newer software
I ended up getting the 2018 part since most folks mentioned on this thread that they had more success with it. Even the 2018 part shape and dimension wise is slightly different, So I had a tough time inserting and shoving all the cables and screwing it in. So you would need to consider the dimensions of the 2019/2020 part compared to 2017 part and see how they fit in.

I recently installed the 2018 part and it does not display any of the software issues folks were discussing on this thread i.e. your fav radio channels disappearing etc. I ordered it from infotainment though and they update the firmware to the latest version before they ship it so not sure if that helped. I also kept the old 2017 parts in case I hit issues and need to go back, I really hope not.
 

·
Registered
Joined
·
13 Posts
I ended up getting the 2018 part since most folks mentioned on this thread that they had more success with it. Even the 2018 part shape and dimension wise is slightly different, So I had a tough time inserting and shoving all the cables and screwing it in. So you would need to consider the dimensions of the 2019/2020 part compared to 2017 part and see how they fit in.

I recently installed the 2018 part and it does not display any of the software issues folks were discussing on this thread i.e. your fav radio channels disappearing etc. I ordered it from infotainment though and they update the firmware to the latest version before they ship it so not sure if that helped. I also kept the old 2017 parts in case I hit issues and need to go back, I really hope not.
Hey
thanks for the update. The issue with infotainment is that they cost a few times over than getting from one of the parts sources. I think the ideal option is to get 2019, will have to wait around till one is available.

Thanks again.
 

·
Registered
Joined
·
2 Posts
I have a 2017 Limited with Harman speakers and the rear Uconnect Theater. Anyone with a similar setup have success with he upgrade? I'd love tp get android auto!
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
I have a 2017 Limited with Harman speakers and the rear Uconnect Theater. Anyone with a similar setup have success with he upgrade? I'd love tp get android auto!
It should not make any difference having the HK system as the difference between the systems is all in the amplifier/speakers ,which is separate from the receiver/screen. You should be good to go.
 

·
Registered
Joined
·
2 Posts
Thanks for the info. One other thought. I have the surround view cameras. Would I need to get a specific unit to ensure they still worked?
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
Thanks for the info. One other thought. I have the surround view cameras. Would I need to get a specific unit to ensure they still worked?
No, the receiver finds the options your vehicle has and displays them. When I first connected mine it showed nothing . No heated/vented seats, no heated wheel, no surround camera etc. But after a short time ,they all showed up. Check out model #'s on here for correct part. (some may or may not have the factory NAV enabled). Sorry, I don't remember what part # mine was, but is was from a 2019 and did include NAV.
 

·
Registered
Joined
·
13 Posts
No, the receiver finds the options your vehicle has and displays them. When I first connected mine it showed nothing . No heated/vented seats, no heated wheel, no surround camera etc. But after a short time ,they all showed up. Check out model #'s on here for correct part. (some may or may not have the factory NAV enabled). Sorry, I don't remember what part # mine was, but is was from a 2019 and did include NAV.
Is the feature tied into the device or the vehicle? I have navi, if I get a device from a vehicle that didn't have the navi, will navi active when I install it into my vehicle?
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
Is the feature tied into the device or the vehicle? I have navi, if I get a device from a vehicle that didn't have the navi, will navi active when I install it into my vehicle?
The Nav software is inside the receiver module I believe.
 

·
Registered
Joined
·
13 Posts
if I am swapping my 2017 system with 2018, do i need to get new screen and brain (UAV) or just replace the brain and the cable? Question is, will my 2017 screen work with 2018 UAV?

Thanks
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
Did you have to get a new 8.4 screen or did your existing screen work with the UAG?

Thanks
Yes, you will need 2018+ screen also.
 

·
Registered
Joined
·
2 Posts
So, a question for those who have completed this upgrade. I purchased the UAV upgrade kit from Infotainment, installed it yesterday, when I first installed, the radio came up and asked for the anti-theft code, Infotainment had included it, so I entered and the radio appeared to work, although some of my options were missing. I did as suggested and turned off the car and let it sit for 20 min, when I returned, radio screen is black. If I press any of the climate controls they appear on the screen, if I put it in reverse, I get the backup camera, but the screen stays blank otherwise. I tried disconnecting the Negative battery terminals to both batteries for 20 minutes. I pulled the F76 fuse for a couple minutes and even replaced it. Let it sit overnight last night... still just a black screen save for pressing the climate controls. It does show the Chrysler splash logo when I turn the vehicle off as well. I put the original radio back in and it works without issue. If anyone has a suggestion, it would be appreciated. I have left 2 messages with Infotainment and no response so far.
 

·
Registered
2017 Pacifica Limited
Joined
·
432 Posts
So, a question for those who have completed this upgrade. I purchased the UAV upgrade kit from Infotainment, installed it yesterday, when I first installed, the radio came up and asked for the anti-theft code, Infotainment had included it, so I entered and the radio appeared to work, although some of my options were missing. I did as suggested and turned off the car and let it sit for 20 min, when I returned, radio screen is black. If I press any of the climate controls they appear on the screen, if I put it in reverse, I get the backup camera, but the screen stays blank otherwise. I tried disconnecting the Negative battery terminals to both batteries for 20 minutes. I pulled the F76 fuse for a couple minutes and even replaced it. Let it sit overnight last night... still just a black screen save for pressing the climate controls. It does show the Chrysler splash logo when I turn the vehicle off as well. I put the original radio back in and it works without issue. If anyone has a suggestion, it would be appreciated. I have left 2 messages with Infotainment and no response so far.
I have not experienced these kind of problems. Because you bought from Infotainment, you should be covered for this, but they are likely on vacay for the holiday period.
 
261 - 280 of 307 Posts
Top