2017+ Chrysler Pacifica Minivan Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Our 2018 Touring L with the premium audio group has had an intermittent radio issue since 2-3 days after taking delivery in December.

The issues all occur at the same time: The SiriusXM radio will not work, the phones that had been paired disappear, and if you try to use the voice control button on the steering wheel, it freezes the touch screen and the radio so that no sound comes from the radio from any source until you turn the car off and on again.

Turning the car off restores the sound to AM and FM but does not always restore FM or the voice command button. Half of the time everything works as it should.

We have taken the car in to the service department at the local dealership three times. They said that they performed an update and fixed it, but when I checked it in the parking lot before I left, the voice command button froze the radio. They planned on replacing the radio, but Chrysler would not let them. They performed more diagnostics on another trip in and Chrysler has decided that all of the problems are due to a previous update and they expect the problem to be resolved by the next "due anytime" update.

Has anyone else had this same type of problem? It does not seem to be the as the UConnect problem that so many others are reporting.
 

·
Registered
Joined
·
1,144 Posts
Your issues appear to be unique here. We have many, many, Uconnect issues, but I have yet to read about someone that has your particular malfunction.

I do understand corporate's reluctance to replace the radio since it is likely a software issue, but even still, replacing the radio might be the quickest fix for you.

FCA is undoubtedly scrambling to address all of these issues, but in the meantime many of us are living with partial functionality. As frustrating (and unfair) as it may seem, being patient may be the path to the quickest resolution.
 

·
Registered
Joined
·
7 Posts
I have the same problems! I finally got a new radio, then the did a software update on it and now it is even worse! It keeps rebooting over and over again!
 

·
Registered
Joined
·
5 Posts
Yes same problems started within 24hrs of taking home the 2018 pacifica touring L plus, was back to dealer today. Still getting same bs about a "fix' that is "coming soon".. unaccceptable!
 

·
Registered
Joined
·
2,474 Posts
I have the same problems! I finally got a new radio, then the did a software update on it and now it is even worse! It keeps rebooting over and over again!
Hi Enjoybirth,
We're glad you reached out with this. We would like to hear more about your concerns and see if there is any opportunity to assist. Please feel free to follow up with us in private messages.
Julie
Chrysler Social Care Specialist
 

·
Registered
Joined
·
1 Posts
More of the same - Intermittent freezing of the display

It seems like Chrysler has just screwed us when it comes to quality for their entertainment/nav system.
Like others posting here, I have been having issues with my 2017 Pacifica's system. Most often it works for a while, but eventually freezes where the touchscreen doesn't work at all. It seems to happen most often when I am connected via Bluetooth, but couldn't say for certain that was the issue.

The dealer has seen my car and witnessed the frozen screen at least 6 times now, and keep saying there is a process Chrysler requires them to follow before the radio can be replaced. First time was logging the issue with Chrysler and they suggested waiting for a software patch. It has been many months since that and now they are going to take it into the shop. I hope they will get approval to replace the system, but fear what others have said; that the problem is poor software. If that is the case I might even be worse off after a replacement. Fingers crossed
 

·
Registered
Joined
·
1 Posts
2018 Pacifica Radio no sound

We bought a new Pacifica in December 2017. Sometime in December 2018 the radio sound started going so low you had to turn up the volume all the way to hear, but then it would jump back and forth to very loud/very soft. This was intermittent, and happened on all settings, stations, etc. Most days it was fine. As of last week there's a new feature where while driving the volume totally disappears. Nothing will bring it back, restarting the vehicle or anything. The display is fine. Of course we're past warranty and who knows what the dealer would charge me to look at it--and that will be one of the times there is no malfunction. Very frustrating!
 

·
Registered
Joined
·
2,474 Posts
We bought a new Pacifica in December 2017. Sometime in December 2018 the radio sound started going so low you had to turn up the volume all the way to hear, but then it would jump back and forth to very loud/very soft. This was intermittent, and happened on all settings, stations, etc. Most days it was fine. As of last week there's a new feature where while driving the volume totally disappears. Nothing will bring it back, restarting the vehicle or anything. The display is fine. Of course we're past warranty and who knows what the dealer would charge me to look at it--and that will be one of the times there is no malfunction. Very frustrating!
Hi JRNCS,
We're sorry to hear about this. We understand how frustrating this may be. Recently there was a Technical Service Bulletin (TSB) that appears to address concerns similar to the symptoms that you are having with your vehicle. To ensure this TSB applies, we would like to get you back into the dealer to have a qualified technician review the details of the TSB and specifics of your vehicle. Once reviewed, the technician can then perform the repair procedure that best matches the symptoms and diagnosis of your vehicle. If you are interested, please send us a private message.
Lydia
Chrysler Social Care Specialist
 

·
Registered
Joined
·
286 Posts
We bought a new Pacifica in December 2017. Of course we're past warranty and who knows what the dealer would charge me to look at it--and that will be one of the times there is no malfunction. Very frustrating!
Your vehicle has a 3 year/36K mile warranty, so you should be fully covered.



<
 

·
Registered
Joined
·
1,912 Posts
We bought a new Pacifica in December 2017. Sometime in December 2018 the radio sound started going so low you had to turn up the volume all the way to hear, but then it would jump back and forth to very loud/very soft. This was intermittent, and happened on all settings, stations, etc. Most days it was fine. As of last week there's a new feature where while driving the volume totally disappears. Nothing will bring it back, restarting the vehicle or anything. The display is fine. Of course we're past warranty and who knows what the dealer would charge me to look at it--and that will be one of the times there is no malfunction. Very frustrating!
If there is a TSB, it would make sense to private message @ChryslerCares with your VIN. Just click on the red letters to message them.
Are you past warranty because of mileage?
To see if there is a UConnect software update (that you might be able to download from a computer to a USB drive) go to the UConnect website and put in your VIN.
https://www.driveuconnect.com/support/software-update.html
 

·
Registered
Joined
·
1 Posts
I have a brand new one that I have had for a month, and I have had the same issue at least 3 times. My audio turns off completely for radio, I connect video, even phone calls. I lose all audio for at least the remainder of the drive. Once I turn off the car and everything has the opportunity to shut down completely, opening the door and everything, then turn it back on, it usually works. Very frustrating and disappointing because I bought this vehicle with the hopes of having it a very long time, but this is not acceptable for a long term vehicle or company to rely on.
 

·
Registered
Joined
·
6 Posts
Our 2018 Touring L with the premium audio group has had an intermittent radio issue since 2-3 days after taking delivery in December.

The issues all occur at the same time: The SiriusXM radio will not work, the phones that had been paired disappear, and if you try to use the voice control button on the steering wheel, it freezes the touch screen and the radio so that no sound comes from the radio from any source until you turn the car off and on again.

Turning the car off restores the sound to AM and FM but does not always restore FM or the voice command button. Half of the time everything works as it should.

We have taken the car in to the service department at the local dealership three times. They said that they performed an update and fixed it, but when I checked it in the parking lot before I left, the voice command button froze the radio. They planned on replacing the radio, but Chrysler would not let them. They performed more diagnostics on another trip in and Chrysler has decided that all of the problems are due to a previous update and they expect the problem to be resolved by the next "due anytime" update.

Has anyone else had this same type of problem? It does not seem to be the as the UConnect problem that so many others are reporting.
Same Issue here, was told it needed software upgrade (did not work) then needed to replace radio (did not work) then they said the touch screen had issues and replaced it and for the a small time period it seems to be okay, then GPS map was off about 30 miles and then receiving message on screen (Vehicle phone require service) red light on rear view mirror stayed lite all the time. Today I was told they needed to replace radio unit again. Really, I need to see if I can claim lemon law on this. because warranty will expire one day and I will have to replace this out of pocket.
 

Attachments

·
Registered
Joined
·
1,912 Posts
Same Issue here, was told it needed software upgrade (did not work) then needed to replace radio (did not work) then they said the touch screen had issues and replaced it and for the a small time period it seems to be okay, then GPS map was off about 30 miles and then receiving message on screen (Vehicle phone require service) red light on rear view mirror stayed lite all the time. Today I was told they needed to replace radio unit again. Really, I need to see if I can claim lemon law on this. because warranty will expire one day and I will have to replace this out of pocket.
If you are seriously thinking of using the lemon law check your state laws since there is usually a time limit and requirements to be documented.
I can understand your frustration, but if your van is under warranty, I would see what the dealer can do to fix it since the lemon law process may take awhile.
If you put your van info (year, trim, gas/hybrid, etc.) and location (state, region, or city) in the signature line it will show up at the bottom of each post.
 

·
Registered
Joined
·
1 Posts
Hi JRNCS,
We're sorry to hear about this. We understand how frustrating this may be. Recently there was a Technical Service Bulletin (TSB) that appears to address concerns similar to the symptoms that you are having with your vehicle. To ensure this TSB applies, we would like to get you back into the dealer to have a qualified technician review the details of the TSB and specifics of your vehicle. Once reviewed, the technician can then perform the repair procedure that best matches the symptoms and diagnosis of your vehicle. If you are interested, please send us a private message.
Lydia
Chrysler Social Care Specialist
I am interested in this. I had notices in the passed week that my radio vol was fluctuating. This morning, the sound totally disappeared. Turning off the radio did not bring the sound back. I have just past the warranty and are at almost 37,000 miles. How much will this cost me?
 

·
Registered
Joined
·
2,474 Posts
I am interested in this. I had notices in the passed week that my radio vol was fluctuating. This morning, the sound totally disappeared. Turning off the radio did not bring the sound back. I have just past the warranty and are at almost 37,000 miles. How much will this cost me?
Hello Tammy Wiseman,

We regret to hear of your vehicle concerns. What is the model year of your vehicle? Please send us a private message as we would be glad to discuss this further with you.

Alex
Chrysler Cares
 

·
Registered
Joined
·
3 Posts
I have a 2019 Pacifica Touring L that I took delivery of in September.
Today I had an odd occurrence with the radio. When I started the car, the radio came on at a very high volume. Thinking I had bumped the volume control when I was putting up the sun shade, I turned the volume down. The volume would either go to mute or to the very high volume. This occurred after I had driven to an appointment and the vehicle had been parked for about an hour. There was no problem with the radio volume on the trip to the appointment.
I tried turning the radio off and on, switching from Sirius to AM to FM and there was no change. I turned the car off and back on again with no change.
I called the service department of the dealership and spoke with a service writer. He said that he had never heard of this happening and it was probably just and adjustment. He suggested that I bring the car by and he would help with adjusting the sound volume.
I went home to let my dogs out before going to the dealership.
Before I got out of the car at home, I once again tried turning things off and on again with no change in results.
After about 30 minutes at home, I got in the car and the radio behaved perfectly normally.
I did drive to the dealership and spoke with a different service writer. I scheduled an appointment for next Tuesday so they can check things and at least get the issue documented.
Does this sound familiar to anyone?
 

·
Registered
Joined
·
9 Posts
Same issue with my 2017 Pacifica. We have had it 1 1/2 years with no issues, then all the sudden it started switching to Aux for no reason, then the screen froze. New radio was installed. Frozen screen still. New touchscreen. Frozen screen. And now tonight the sound is gone, screen still frozen. We are taking it back tomorrow for them to look at. Getting very frustrated. The dealership said they haven't seen this problem before.
 

·
Registered
Joined
·
1 Posts
I have a 2019 Pacifica Touring L that I took delivery of in September.
Today I had an odd occurrence with the radio. When I started the car, the radio came on at a very high volume. Thinking I had bumped the volume control when I was putting up the sun shade, I turned the volume down. The volume would either go to mute or to the very high volume. This occurred after I had driven to an appointment and the vehicle had been parked for about an hour. There was no problem with the radio volume on the trip to the appointment.
I tried turning the radio off and on, switching from Sirius to AM to FM and there was no change. I turned the car off and back on again with no change.
I called the service department of the dealership and spoke with a service writer. He said that he had never heard of this happening and it was probably just and adjustment. He suggested that I bring the car by and he would help with adjusting the sound volume.
I went home to let my dogs out before going to the dealership.
Before I got out of the car at home, I once again tried turning things off and on again with no change in results.
After about 30 minutes at home, I got in the car and the radio behaved perfectly normally.
I did drive to the dealership and spoke with a different service writer. I scheduled an appointment for next Tuesday so they can check things and at least get the issue documented.
Does this sound familiar to anyone?
Same issue just happened to me tonight. Turn it to 1 and it's blaring, turn to 0 and nothing. Any ideas as to what is wrong?
 
1 - 20 of 23 Posts
Top