2017+ Chrysler Pacifica Minivan Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My wife called me today that she started to smell a strong rotten smell in her 2017 Chrysler Pacifica.

Shortly after the start/stop unavailable message came back.

When she got home I could smell the strong rotten smell seemed to be coming from the small battery next to the larger battery under the hood.

Just reached 38k miles and out of warranty.

Has anyone had this happen to them?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,117 Posts
Hi @zeprider25,

We're sorry to hear this! We know that you are currently seeking advice from other forum members, however, we recommend visiting your dealer to have this diagnosed. Please send our team a message if you would like additional support while in service.

Darlene
Chrysler Social Care Specialist
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Hi @zeprider25,

We're sorry to hear this! We know that you are currently seeking advice from other forum members, however, we recommend visiting your dealer to have this diagnosed. Please send our team a message if you would like additional support while in service.

Darlene
Chrysler Social Care Specialist
Dealer said I was out of warranty. The aux battery had swollen up which was the cause of the smell. It had 2.4v out of the 12v .

I replaced the battery myself as the dealer was going to charge me about $300+ .

So far no further issues or messages on the dashboard


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Spoke to soon. Made it about a week and the start stop message came back. Unknown if related but ever since I replaced the auxiliary battery my rear bumper sensors have been acting crazy sometimes triggering my brakes when there’s nothing behind me and my radio doesn’t shut off when I turn off the car and exit. (It shuts off eventually about a min after)




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,117 Posts
Spoke to soon. Made it about a week and the start stop message came back. Unknown if related but ever since I replaced the auxiliary battery my rear bumper sensors have been acting crazy sometimes triggering my brakes when there’s nothing behind me and my radio doesn’t shut off when I turn off the car and exit. (It shuts off eventually about a min after)




Sent from my iPhone using Tapatalk
Hi zeprider25,

We're very sorry to hear of this happening again. As we are not mechanically trained on our end, we do recommend visiting your dealer to have this diagnosed. If you can confirm an appointment, we would be glad to escalate a case to our internal handling team for you. They will be able to work alongside your dealer to work toward a solution.

Alex
Chrysler Cares
 
1 - 7 of 7 Posts
Top