2017+ Chrysler Pacifica Minivan Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Went out to my 2018 PacHy earlier this week and it was dead. Called Chrysler Roadside Assistance who sent someone out to jumpstart my car. Car started but wouldn't shift out of park and gave the "Service Transmission" message. Called Roadside Assistance again, they sent out a platform truck to bring it to the dealer. Since it wasn't shifting out of park the attendant needed to drag it onto his truck (something I read about happening to others on here, very painful to watch). It is now at the dealer where they informed the Roadside Assistance guy that they were backed up and wouldn't be able to look at it for a week. As noted in my title, I am 500 miles from home and need to leave this weekend.

Was referred to Chrysler Cares and have a case manager who informed me that they would not be getting me a rental but would ask the dealer to give me a loaner (but no guarantees). Case manager also informed me that since it was a holiday week it might be Friday before he gets back to me but he will be working with the dealer to see if they could expedite the servicing of my car. I do not have high hopes that anything will be done before I am supposed to leave

Has anyone else been an a similar situation? Would a dealer be Ok with me having a loaner that travels over 1000 miles (home and back up for car)? Do I have any recourse if the car is not finished by the time I need to leave and they do not provide me a loaner?

We are in a fairly rural area in Upstate NY and there are not any other dealerships nearby. Car has 23,000 miles. Called insurance to see if they could help but I only get rental coverage if I have been in an accident.

Any other suggestions?
 

·
Super Moderator
Joined
·
674 Posts
Hi welcome to the forum. I unfortunately don't have any suggestions. I just wanted to let you know that your thread was awaiting approval since you're new. It's approved so you should get some feedback soon from the great community of members that we have here.
 

·
Registered
Joined
·
44 Posts
Went out to my 2018 PacHy earlier this week and it was dead. Called Chrysler Roadside Assistance who sent someone out to jumpstart my car. Car started but wouldn't shift out of park and gave the "Service Transmission" message. Called Roadside Assistance again, they sent out a platform truck to bring it to the dealer. Since it wasn't shifting out of park the attendant needed to drag it onto his truck (something I read about happening to others on here, very painful to watch). It is now at the dealer where they informed the Roadside Assistance guy that they were backed up and wouldn't be able to look at it for a week. As noted in my title, I am 500 miles from home and need to leave this weekend.



Was referred to Chrysler Cares and have a case manager who informed me that they would not be getting me a rental but would ask the dealer to give me a loaner (but no guarantees). Case manager also informed me that since it was a holiday week it might be Friday before he gets back to me but he will be working with the dealer to see if they could expedite the servicing of my car. I do not have high hopes that anything will be done before I am supposed to leave



Has anyone else been an a similar situation? Would a dealer be Ok with me having a loaner that travels over 1000 miles (home and back up for car)? Do I have any recourse if the car is not finished by the time I need to leave and they do not provide me a loaner?



We are in a fairly rural area in Upstate NY and there are not any other dealerships nearby. Car has 23,000 miles. Called insurance to see if they could help but I only get rental coverage if I have been in an accident.



Any other suggestions?


Had this same thing occur to me on my 2018 that I bought july 4th. Sounds like battery issue.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
279 Posts
@dorysblue, it's been several days since your misfortune, what if anything did they do for you? Has your vehicle been repaired and what was the issue?



<
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Update

Thanks so much to those who responded.

The problem with my car was a broken park pawl. According to the service manager, that was the root of the entire problem. When that broke it tripped a circuit breaker. They replaced the part and everything seems to be working fine. I am not a mechanically oriented or car person so apologies if I have not explained the problem well.

As for the customer service portion of the event, I was underwhelmed. I was eventually promised a loaner from the local dealership but by then I was already home and when I came back up my car was done. My Chrysler Cares rep seemed unsympathetic and uninterested in my situation. Each time he called I needed to remind him of my case. He never remembered I was no longer in the area. Example: he called to let me know he had secured me a loaner even though I told him I wasn't in the area any more. I asked him if it would be ok if I picked up the loaner when I returned to the area in a couple of days, he said yes but then called me the next day to see if my loaner was ok. He was never rude, I just felt like he didn't care. Also never felt like he was fighting for me to get reimbursed for a rental or other transportation back up to my car. I ended up buying a train ticket since it was cheaper than a one way car rental. I understand he was there to protect Chrysler's interests and not mine, I just wish it wasn't so obvious!

I do have one remaining problem, one of the rear seat theatre screens isn't working. If anyone has any ideas about fixes for that, I'd love to hear them. It's not the contrast.

Thanks again all!
 

·
Registered
Joined
·
1,706 Posts
Thanks so much to those who responded...

I do have one remaining problem, one of the rear seat theatre screens isn't working. If anyone has any ideas about fixes for that, I'd love to hear them. It's not the contrast.

Thanks again all!
Glad you were able to get your van fixed and home.
I don't have theater screens in my van, but I would suggest you do a forum search in that category and try to find a thread close to the problem and ask there. If there isn't a thread related to the problem, you can start a new thread and someone might help you faster than if the question is in a "stranded" thread.

If you put your van info (year, trim, gas/hybrid, etc.) in the signature line of the UserCP, it will show up at the bottom of each post and might also help others wanting to assist you. Welcome to the forum.
 

·
Registered
Joined
·
1,809 Posts
Thanks for the update. Your described the problem cause perfectly. Sorry for the giant waste of time it was. You may try puling fuse 54 to reset the Theater, it might help.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Thanks again, everyone! Home now, car made it back just fine and in 100 degree heat!

Thanks also for the tips on enhancing and improving my forums experience and on the screen problem.
 
1 - 9 of 9 Posts
Top