2017+ Chrysler Pacifica Minivan Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Newbie here, so direct me to the correct threads.

The Mrs and I have 2 smartphones with nav/gps. I'm iPhone centric, she's Android. We have Android Auto and CarPlay. Several times in the last few months of ownership, uConnect will fail to recognize either phone with multiple attempts, nothing on the main screen. It is not the phones, both will do the GPS thing, but won't connect to uConnect. After an overnight shutdown, next day, all is well. Really annoying in a snow storm in Wy for two Bama residents. It appears that uConnect updates randomly. Is there a schedule, a website, whatever that will tell us when uConnect is not going to work? I bought a $40 garmin gps as a backup and it worked flawlessly and in fact became the primary gps. If this continues, my $38k+ pacifica will be traded for another (#7) Odyssey next time.
 

·
Registered
Joined
·
1,975 Posts
Newbie here, so direct me to the correct threads.

The Mrs and I have 2 smartphones with nav/gps. I'm iPhone centric, she's Android. We have Android Auto and CarPlay. Several times in the last few months of ownership, uConnect will fail to recognize either phone with multiple attempts, nothing on the main screen. It is not the phones, both will do the GPS thing, but won't connect to uConnect. After an overnight shutdown, next day, all is well. Really annoying in a snow storm in Wy for two Bama residents. It appears that uConnect updates randomly. Is there a schedule, a website, whatever that will tell us when uConnect is not going to work? I bought a $40 garmin gps as a backup and it worked flawlessly and in fact became the primary gps. If this continues, my $38k+ pacifica will be traded for another (#7) Odyssey next time.
Welcome to the forum. If you put your van info (year, trim, gas/hybrid, etc.) in the signature line of the UserCP it will show up at the bottom of each post and help others answer your questions.

You can download a UConnect manual and check for updates on the UConnect website by putting in your VIN.
https://www.driveuconnect.com/

You can private message @ChryslerCares by clicking on the red letters and see if there are any suggestions for your VIN.

I'm pretty sure a phone has to be connected to the touchscreen with a cord for Android Auto/car play, but it doesn't surprise me that there might not be cell reception some places in Wyoming. The Android Auto mirrors the cell phone so I assume the cell phone needs reception for Android Auto/Car Play to work. I don't have experience with Android Auto on my Pacifica but am familiar with it on another vehicle.

If you list which phone models you are using, others with a similar phone might assist you. I found that a Samsung S5 worked better than an S4 with the 2017 UConnect system.

There is a search feature on the forum that you can try to use to find more threads to read.
Here is one thread to start with.
https://www.pacificaforums.com/forum/433-2017-chrysler-pacifica-phev-hybrid-general-discussion/39198-ota-issued-july-14th-2018-a.html?nojs=1#goto_threadtools
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks for the quick response, I'll update my info later. 2018 gas Pacifica. Android phone Samsung Galaxy S7, iPhone 6s Plus. uConnect failures in AL, La, Ms, and Wy. Cell coverage at all those times as we both had maps available on our phones, were receiving texts, and could make calls. I'll do the vin check suggested. Great stuff, thanks.
 

·
Registered
Joined
·
2,504 Posts
Thanks for the quick response, I'll update my info later. 2018 gas Pacifica. Android phone Samsung Galaxy S7, iPhone 6s Plus. uConnect failures in AL, La, Ms, and Wy. Cell coverage at all those times as we both had maps available on our phones, were receiving texts, and could make calls. I'll do the vin check suggested. Great stuff, thanks.
Hi Unclerap,
We're sorry to hear about this! We completely understand how frustrating this may be. Please send us a private message and we will gladly look into this a bit further for you.
Lydia
Chrysler Social Care Specialist
 

·
Super Moderator
Joined
·
730 Posts
Newbie here, so direct me to the correct threads.

The Mrs and I have 2 smartphones with nav/gps. I'm iPhone centric, she's Android. We have Android Auto and CarPlay. Several times in the last few months of ownership, uConnect will fail to recognize either phone with multiple attempts, nothing on the main screen. It is not the phones, both will do the GPS thing, but won't connect to uConnect. After an overnight shutdown, next day, all is well. Really annoying in a snow storm in Wy for two Bama residents. It appears that uConnect updates randomly. Is there a schedule, a website, whatever that will tell us when uConnect is not going to work? I bought a $40 garmin gps as a backup and it worked flawlessly and in fact became the primary gps. If this continues, my $38k+ pacifica will be traded for another (#7) Odyssey next time.

At least for Android Auto, the connection is very peculiar about the cable that is being used. Most aftermarket cables didn't work well for me. They would work intermittently and freeze Uconnect or Cadillac cue in my Cadi or the Sony Android auto deck in my Landcruiser. If you're using aftermarket cables, might try switching to a different cable and see if it helps.
 

·
Registered
Joined
·
7 Posts
Same situation here...I have Android S8+, wife has iPhone 8...couple times a week, Uconnect fails to see our phones and we have to go through the Pairing process all over again...very frustrating. No issues with cell service, and sometimes if you wait til the next day, the system has our phones connected again like nothing happened...


Also, when using Pandora through the Android Auto app, if I hit the "Thumbs Down" or "Skip to next song" buttons on the screen, it just freezes up the system and won't play any more Pandora til a key off sequence is done...I can go play SiriusXM or radio, but Pandora/Uconnect is frozen. Odd.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
UPDATE

We are using the original Android and Apple power/data cords. Chrysler attempted to contact me, but we are playing phone tag. Really good response time. Much better than Honda or Kia, so altho there isn't a solution yet, at least there is an attempt to make contact. The vehicle is performing as expected, some of the safety features are superior to anything we've had before: BMW, Kia, Honda, GM, Ford, etc. We buy a vehicle every 2-3 years, so if this one doesn't measure up, it's gone. But, with the uConnect actually connecting or if I can get a schedule when it won't connect, this one may stay in the family for a long time.

Performance-wise this gas Pacifica is superior to any previous van: 2015 Kia, and several Odysseys dating back to 2002.

Thanks to all who are responding and helping.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
06/11/2019 update:

uConnect continues to fail randomly. Talked to Mopar cust service for over an hour to day and the answer: Take it back to the dealer. On the schedule today, I'll report outcome, but this is annoying to the point of re-thinking the wisdom of the mopar purchase. The $40 garmin gps I got on ebay continues to work flawlessly.
 

·
Registered
Joined
·
35 Posts
I have had issues, still unresolved, with Android Auto not connecting to Uconnect (data connection error). The S9 and several cables, both OEM and aftermarket cables dont make any difference. I would gladly buy a USB cable from chrysler if they can sell me one that is working instead of saying 'your cable doesnt work'. There is something more to this, and if the radio/nav unit or the USB module is so picky and fickle about the data cables for android phones, then chrysler should supply or at least sell one that works. BTW, apple carplay works every time I connect an iphone 6,no matter what brand of cable I use.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
June 2019 UPDATE

Contacted uConnect customer service by phone. After an hour with uCS (original power cord required, correct data port, bluetooth on, bluetooth interfaced to iPhone) all the routine things we have done several times previously, the final answer: We can't help you, but you have an update available, take it to the dealer. At the dealer, they were unaware an update is available but said they would get it, but it would require several hours for them to download it to their system, and further serveral hours to download to my 2018 Pacifica Touring L. The dealer said they'd call me to schedule the update once they have it. So, yet another trip to the dealer without resolution. The dealer did say that if the update doesn't cure the problem, a new uConnect system is the only way to fix it. So far the van is under warranty, but the miles tick away daily. I asked the dealer if uConnect does wireless updates, answer: Yes, but you will get a screen notification and authorization. This has never happened with our system.

Another oddity: When I visit the uConnect website, using my log in and password I get a notification "no account registered." I tried to re-register but it didn't work.

RANT: I have a $199 smartphone that udates via cell or wifi several times a year, and I get notifications of impending updates. On my $38,000 Pacifica I get zero notifications, it has failed 3 times in the past 8 months, and I must inform the dealership of an available update, make a second trip to that dealership for the update after calling uConnect customer service. Something isn't right with that picture.

While the rest of the vehicle performs as expected, the uConnect failures have gone far beyond simple annoyance. Our current dependable navigation tool is a $40.00 Garmin bought on eBay. Or my cellphone. Our state has a "hands free" law, so the saftey and convienence of uConnect was one of our buying decisions.
 

·
Registered
Joined
·
2,504 Posts
June 2019 UPDATE

Contacted uConnect customer service by phone. After an hour with uCS (original power cord required, correct data port, bluetooth on, bluetooth interfaced to iPhone) all the routine things we have done several times previously, the final answer: We can't help you, but you have an update available, take it to the dealer. At the dealer, they were unaware an update is available but said they would get it, but it would require several hours for them to download it to their system, and further serveral hours to download to my 2018 Pacifica Touring L. The dealer said they'd call me to schedule the update once they have it. So, yet another trip to the dealer without resolution. The dealer did say that if the update doesn't cure the problem, a new uConnect system is the only way to fix it. So far the van is under warranty, but the miles tick away daily. I asked the dealer if uConnect does wireless updates, answer: Yes, but you will get a screen notification and authorization. This has never happened with our system.

Another oddity: When I visit the uConnect website, using my log in and password I get a notification "no account registered." I tried to re-register but it didn't work.

RANT: I have a $199 smartphone that udates via cell or wifi several times a year, and I get notifications of impending updates. On my $38,000 Pacifica I get zero notifications, it has failed 3 times in the past 8 months, and I must inform the dealership of an available update, make a second trip to that dealership for the update after calling uConnect customer service. Something isn't right with that picture.

While the rest of the vehicle performs as expected, the uConnect failures have gone far beyond simple annoyance. Our current dependable navigation tool is a $40.00 Garmin bought on eBay. Or my cellphone. Our state has a "hands free" law, so the saftey and convienence of uConnect was one of our buying decisions.
Hi Unclerap,
We're sorry to see that you are still experiencing these difficulties with your Uconnect system. Please let us know if the software update helps. We're available via private message if you need any additional assistance!
Lydia
Chrysler Social Care Specialist
 

·
Registered
Joined
·
1,975 Posts
June 2019 UPDATE

Contacted uConnect customer service by phone. After an hour with uCS (original power cord required, correct data port, bluetooth on, bluetooth interfaced to iPhone) all the routine things we have done several times previously, the final answer: We can't help you, but you have an update available, take it to the dealer. At the dealer, they were unaware an update is available but said they would get it, but it would require several hours for them to download it to their system, and further serveral hours to download to my 2018 Pacifica Touring L. The dealer said they'd call me to schedule the update once they have it. So, yet another trip to the dealer without resolution. The dealer did say that if the update doesn't cure the problem, a new uConnect system is the only way to fix it. So far the van is under warranty, but the miles tick away daily. I asked the dealer if uConnect does wireless updates, answer: Yes, but you will get a screen notification and authorization. This has never happened with our system.

Another oddity: When I visit the uConnect website, using my log in and password I get a notification "no account registered." I tried to re-register but it didn't work.

RANT: I have a $199 smartphone that udates via cell or wifi several times a year, and I get notifications of impending updates. On my $38,000 Pacifica I get zero notifications, it has failed 3 times in the past 8 months, and I must inform the dealership of an available update, make a second trip to that dealership for the update after calling uConnect customer service. Something isn't right with that picture.

While the rest of the vehicle performs as expected, the uConnect failures have gone far beyond simple annoyance. Our current dependable navigation tool is a $40.00 Garmin bought on eBay. Or my cellphone. Our state has a "hands free" law, so the saftey and convienence of uConnect was one of our buying decisions.
Did you try to put your VIN in on the UConnect page to check for updates?
https://www.driveuconnect.com/support/software-update.html
Theoretically, you can download the update onto a USB and update the UConnect software yourself. After downloading info from a computer onto the USB, the USB goes in the slot by the touchscreen. I haven't done it, but others on the forum have.
https://www.pacificaforums.com/forum/460921-post3.html
If it doesn't work at home, print the update page and take it with you to the dealer. If your van is under warranty, the dealer should be able to update it at no charge. It seems incredible that they think it will take several hours. Sounds like they don't want to do it, but if your van is under warranty, they should do it.

How long was the free trial for UConnect for your van? Maybe it is expired which is why logging in didn't work.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Using the uConnect link and my VIN, "no updates available".

From the "go figure" dept. This morning it works. iPhones, carplay and uConnect are in sync. Still heading to the dealer when they call for the update. IDK if it's a coincidence but both times ChryslerCares posts to this thread, my uConnect works shortly thereafter.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
The free trial is one year, I assumed from date of purchase, but the van was clearly mfgd prior to that, additionally there were a couple of misfires by the dealer regarding delivery date and reupholstering the seats that delayed the delivery over 2 weeks. Maybe you are right, the free time has expired? Picked it up the last day of Aug, 2018.

But back online today.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
UPDATE 06.20.2019

uConnect has worked for the last few days. The dealer did an update that changed the format on the uConnect screen, not a problem. However I had to reset all my favorites on XM and the radio. And further, every start I must rest all the favorites. I really think uConnect is not ready for prime time. It is an immature product that the paying customer is the beta tester. Getting less happy with my purchase every drive.
 

·
Registered
Joined
·
189 Posts
I'm a long time member of this forum. I ordered my Van from the factory. It's a gas 2018 Pacifica limited. Overall the van has performed very well except for my Android Auto.

Same thing happens to me as others have described, it just randomly stops working or connecting and I have to wait sometimes overnight or several days before it works or connects again. Also I have noticed that the USB stops charging during the time Android auto stops working. I have taken it to the dealer and reported these issues and they tell me the same thing that it's my phone or cable.
I'm very annoyed because we're currently on a road trip and having android auto issues. I really want this feature to be dependable because when it works it makes things very convenient while traveling.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
35 Posts
I have had issues, still unresolved, with Android Auto not connecting to Uconnect (data connection error). The S9 and several cables, both OEM and aftermarket cables dont make any difference. I would gladly buy a USB cable from chrysler if they can sell me one that is working instead of saying 'your cable doesnt work'. There is something more to this, and if the radio/nav unit or the USB module is so picky and fickle about the data cables for android phones, then chrysler should supply or at least sell one that works. BTW, apple carplay works every time I connect an iphone 6,no matter what brand of cable I use.
Update on the non working Android Auto issue..

Its finally fixed after a new radio/nav and usb module was installed. It took the dealership and Chrysler 2 weeks of troubleshooting, diagnostics and negotiations to order a new radio unit, and another 8 days for the unit to arrive at the shop and couple more days to schedule and install it. Overall, a turnaround time of almost a month after the van was brought into the shop as per Chrysler's direction. It was pretty clear from the outset when Apple CarPlay worked but not Android Auto, it wasnt the phone or the cables or the USB or the software. But, i guess it takes couple of weeks to figure that out.

Rather disappointed in the way these things work at Chrysler and/or dealership to get an issue fixed, that is not something complex or intermittent. I guess other than the basic oil change or brake jobs for which they'll charge you an arm and a leg, you cant expect much from them.
 
1 - 17 of 17 Posts
Top