2017+ Chrysler Pacifica Minivan Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I love the 2017 Pacifica we just got - but have been frustrated to no end with stuff not working :( First the glass over the cluster had to be replaced because there was a scratch on the inside. Then with about 2000 miles on it... the cluster itself goes out. That was fixed right before vacation - and while on vacation, the UConnect Theater screens behind the driver and passenger seats are now black. Less than 3000 miles on the thing - and looking forward to our 3rd repair... :(

Has anyone experienced this with UConnect Theater screens? They used to come on when we flipped them up - now they are black. Remote control power does nothing. I've done the reset on the Uconnect system (hold the two physical buttons so it resets... Mute and whatever the other button is)... it reboots, and they still don't come on. I've seen other people having issues with them.... just curious if there is anything else I might try before calling the dealer for yet another service visit.

Thanks in advance - vehicle itself runs great, its really comfortable but it can be frustrating when all the fancy gadgets we paid extra for simply don't work.
 

·
Registered
Joined
·
71 Posts
That's unfortunate. I've had instances where the screen doesn't come on, but power cycling or switching the power on and off on the screen normally does the trick. If not that, then I've also had luck by navigating to a video on the USB from the front monitor and turning it on from there.

I can understand your pain, as we got this van specifically for the UConnect system and we are going through the growing pains of a first year run on this production.
 

·
Registered
Joined
·
8 Posts
Were you able to resovle this? My 2018 Pachy limiteds back 2 screens went blank 2 days ago and havent been able to restart it. Hesitant to take it to dealer but I guess thats the only way.
 

·
Registered
Joined
·
1,144 Posts
Were you able to resovle this? My 2018 Pachy limiteds back 2 screens went blank 2 days ago and havent been able to restart it. Hesitant to take it to dealer but I guess thats the only way.
Did you try removing and installing fuse F55? It is a 2 segment fuse and the "B" half controls the Video Routing Module (VRM) that some have had success with fixing back screen issues.
 

·
Registered
Joined
·
8 Posts
Did you try removing and installing fuse F55? It is a 2 segment fuse and the "B" half controls the Video Routing Module (VRM) that some have had success with fixing back screen issues.
I had tried removing and reinstalling F76 before I posted here. I tried with F55 yesterday - removed it for a couple of minutes and reinstalled it - but no change. :crying:
 

·
Registered
Joined
·
9 Posts
Any luck with this? I've had this happen to me for the second time and have a service scheduled with the dealer now. The first time I was able to get it working with a factory reset and battery disconnect but I really don't want to do that again. I tried pulling fuses and didn't find one that worked. I have a 2017 PacHy.
 

·
Registered
Joined
·
8 Posts
Tried this yesterday - but dint come up. Taking it to the dealer this weekend. Was planning a long drive over the weekend, but will have to wait till this gets fixed.
 

·
Registered
Joined
·
8 Posts
Tried this yesterday - but dint come up. Taking it to the dealer this weekend. Was planning a long drive over the weekend, but will have to wait till this gets fixed.
Argh, now dealer says no tech available this time. And wants me to drop off the vehicle to be looked at sometime during the week...
Sucks!
 

·
Registered
Joined
·
1 Posts
Black screens in Row 2

We do love our 2018 Pacifica Hybrid, so it was mud in the eye when we proudly insisted that the grandkids ride in back and try the great games. This is after six months of no issues at 13000 miles.
No screens! No power switch! No virtual reset! Remote? worthless without a screen! Oh well, maybe disappointment builds character.
Trouble shooting was a fruitless nightmare, since there is very little documentation for UConnect--even in the downloadable owners manual. After I gave up on the APP and the THEATER touchscreen options, I got on the computer and found this great forum.
If it ever stops raining tomorrow I will just have to pull fuse F76 and hope that resets it.
I will report back either way.
 

·
Registered
Joined
·
11 Posts
I tried pulling the F55 and F76 fuses. That did the trick for me. Both rear screens turn on when I lift the screens. I have not tried to update the VRM. I have the update saved on my computer, just too lazy to do it.
 

·
Registered
Joined
·
1 Posts
We love our 2017 Pacifica. One of the selling points was the UConnect Theater system. Unfortunately, we have never been able to play the game apps, only able watch movies in the 2nd row. Anytime we select a game app (any of them), the screen goes black. The only way to get the screen back is to restart the entire system (car restart). We just updated the system software hoping that would resolve the issue, but we get the same results. Can anyone help?
 

·
Registered
Joined
·
2,474 Posts
We love our 2017 Pacifica. One of the selling points was the UConnect Theater system. Unfortunately, we have never been able to play the game apps, only able watch movies in the 2nd row. Anytime we select a game app (any of them), the screen goes black. The only way to get the screen back is to restart the entire system (car restart). We just updated the system software hoping that would resolve the issue, but we get the same results. Can anyone help?
Hi @GA_Dad,

We're sorry to hear that you are unable to play the games on the Uconnect Theater system. Please send our team a private message with your VIN and mileage so that we can look into this further.

Darlene
Chrysler Cares
 

·
Registered
Joined
·
3 Posts
We own a 2019 Hybrid Limited and have the issue that the back seat screen (driver side) functions about 10% of the time. The other one works fine. It's been for this about 6 months now. Tried a number of things including all the resets etc and replacing fuse 55, but no structural improvement.

I'm at a loss here, and since we imported this car to Europe we don't have a dealer here who knows this car and can help us out. Any other options we can try?

Thanks in advance!
 

·
Registered
Joined
·
3 Posts
Our 2017 Does an odd thing with the rear screens too. When we start the vehicle they power up when opened up. Then as soon as the kids go to open a game from either one they both blank out. Kind of disappointing tbh. They stay blank until the vehicle is stopped and turned off and locked.
 
1 - 20 of 20 Posts
Top