2017+ Chrysler Pacifica Minivan Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
After driving for a while I get the message "vehicle phone requires service". I tried a reset of the Uconnect then I lost the time and navigation shows the wrong location. If I let the gps set the time it's off by several hours. I can manually set the time, but the navigation shows me in the wrong location.
 

·
Registered
Joined
·
3,343 Posts
After driving for a while I get the message "vehicle phone requires service". I tried a reset of the Uconnect then I lost the time and navigation shows the wrong location. If I let the gps set the time it's off by several hours. I can manually set the time, but the navigation shows me in the wrong location.
Okay , how about model and year and trim line . Did you reboot the phone ?
 

·
Registered
Joined
·
780 Posts
I am unfamiliar with this message and not sure what it is in reference to.
 

·
Registered
Joined
·
3,343 Posts
Sometimes resetting or nav recalibration is going to a parking lot and turn a 3 x in a clockwise rotation . When you did a soft reset of the uconnect did you also unpair your phone to the system and then pair it back up .
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
I didn't have my cell phone paired. The vehicle phone is built into the van. It's used for 911 calls. It's not working anymore. When I do the 3x turns do I need to push some setting for recalibration?
 

·
Registered
Joined
·
480 Posts
Pacifica has NO phone...
 

·
Registered
2021 Pacifica Hybrid Touring-L Plus
Joined
·
146 Posts
It’s a problem with the telematics box in the vehicle. Are you still under warranty?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #13 ·
No I don't use the features, but the red light on the visor and message on the screen bug me. I also noticed my navigation shows me in the wrong location by several miles and the direction of travel is incorrect. Are these related?
 

·
Registered
2021 Pacifica Hybrid Touring-L Plus
Joined
·
146 Posts
No I don't use the features, but the red light on the visor and message on the screen bug me. I also noticed my navigation shows me in the wrong location by several miles and the direction of travel is incorrect. Are these related?
They could be. This vehicle has something called an RF Hub, which controls a lot of the radios. There could be an issue with that RF Hub which is messing up the cellular radio and the GPS reception. You’d need a dealer to diagnose. If you have an OBD scanner you could look for codes as well.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #15 ·
They could be. This vehicle has something called an RF Hub, which controls a lot of the radios. There could be an issue with that RF Hub which is messing up the cellular radio and the GPS reception. You’d need a dealer to diagnose. If you have an OBD scanner you could look for codes as well.
My satellite radio Sirius XM works fine.
 

·
Registered
Joined
·
2,846 Posts
After driving for a while I get the message "vehicle phone requires service". I tried a reset of the Uconnect then I lost the time and navigation shows the wrong location. If I let the gps set the time it's off by several hours. I can manually set the time, but the navigation shows me in the wrong location.
Hi Tucson Tom,
We see that you have received some great advice from your fellow forum members! However, if these suggestions do not address your concern and you decide to visit your dealer, our team would be happy to offer additional assistance throughout that process! We're available via private message.

Rob
Chrysler Cares
 

·
Registered
Joined
·
2,846 Posts
Ya I don't exactly know what runs through the RF Hub, just that it exists. You'd need a dealer to look at it or message @ChryslerCares for assistance.
Thank you for the tags!

Rob
Chrysler Cares
 
1 - 18 of 18 Posts
Top